Bug 40818 - Visual Studio not able to resolve anything
Summary: Visual Studio not able to resolve anything
Status: VERIFIED ANSWERED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 4.1.0 (C7)
Hardware: PC Windows
: Normal normal
Target Milestone: 4.1.0 (C7)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-05-03 11:30 UTC by Rosdi
Modified: 2016-05-05 19:45 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
The project sample, and a build log file. (287.85 KB, application/x-zip-compressed)
2016-05-03 11:30 UTC, Rosdi
Details
Screenshot of my visual studio (105.46 KB, image/png)
2016-05-03 11:31 UTC, Rosdi
Details
Xamarin Diagnostic file (6.62 KB, text/plain)
2016-05-03 11:32 UTC, Rosdi
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED ANSWERED

Description Rosdi 2016-05-03 11:30:29 UTC
Created attachment 15884 [details]
The project  sample, and a build log file.

I am following a tutorial at https://www.jimbobbennett.io/building-a-xamarin-android-app-part-5/

All was fine until suddenly I am not able to build the project.

Attached is a log from visual studio, and also the project itself.
Comment 1 Rosdi 2016-05-03 11:31:05 UTC
Created attachment 15885 [details]
Screenshot of my visual studio
Comment 2 Rosdi 2016-05-03 11:32:15 UTC
Created attachment 15886 [details]
Xamarin Diagnostic file
Comment 4 Rosdi 2016-05-05 03:12:57 UTC
Hi,

The errors are gone and the project builds successfully after I removed these two lines from `Resources\layout\counter_view.xml`

    card_view:cardElevation="8dp"
    card_view:cardCornerRadius="8dp"

I have no idea what these two are for or why they are causing the build errors... I am new to Xamarin.

Is this a bug in Xamarin or is it because I am targeting wrong Android API level?
Comment 5 Rosdi 2016-05-05 03:20:09 UTC
Looks like it is target SDK version issue as explained here: https://components.xamarin.com/gettingstarted/xamandroidsupportv7cardview

Nevertheless... I don't suppose Visual Studio to bomb like that?
Comment 6 Ben Beckley 2016-05-05 19:45:19 UTC
Yes, you need the "Android Support Library v7 CardView" package to use those resource values.