Bug 40799 - Building iOS application from Visual Studio can take 5-8 minutes
Summary: Building iOS application from Visual Studio can take 5-8 minutes
Status: VERIFIED DUPLICATE of bug 40726
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Debugger ()
Version: 4.1.0 (C7)
Hardware: PC Windows
: High critical
Target Milestone: 4.1.0 (C7)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-05-02 07:49 UTC by Gergely Oroszi
Modified: 2016-05-10 17:05 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED DUPLICATE of bug 40726

Description Gergely Oroszi 2016-05-02 07:49:26 UTC
It happens if a build is started from Visual Studio 2015 Enterprise, in case of iOS class library, when it is being compiled, the VS is doing nothing visible, just after 5-8 minutes it continues the build with the runnable iOS project, which needs additional minutes to be compiled. A Mac Mini and a PC is used, below you can see the config.

MacMini
 - Late 2012
 - 2,5 Ghz Intel Core i5
 - 10 GB 1600 Mhz DDR3
 
PC
 - Intel Core i5-3470S @ 2.90 Ghz
 - 16 GB DDR3 (15.8 GB usable)
 - 64 bit operating system
Comment 1 Ben Beckley 2016-05-02 21:45:33 UTC
Hello Gergely,

We are currently investigating slow build times. Could you please provide some additional information by following the steps in Bug 40726 Comment 5? The link is below:

https://bugzilla.xamarin.com/show_bug.cgi?id=40726#c5
Comment 4 Ben Beckley 2016-05-04 14:55:15 UTC
Thank you for the log file. It appears that the issue is around the PackLibraryResources task. We are currently working on a fix for this.

13>      153 ms  CollectBundleResources                     1 calls
13>      153 ms  SayGoodbye                                 1 calls
13>      550 ms  ConvertPdbToMdb                            1 calls
13>      807 ms  Csc                                        1 calls
13>     1374 ms  MSBuild                                   16 calls
13>     6360 ms  SayHello                                   1 calls
13>    293298 ms  PackLibraryResources                       1 calls
13>
13>Build succeeded.


I will mark this as a duplicate to focus tracking in one location

*** This bug has been marked as a duplicate of bug 40726 ***