Bug 40796 - Mapbpox Android Sample does not compile
Summary: Mapbpox Android Sample does not compile
Status: RESOLVED NORESPONSE
Alias: None
Product: Components
Classification: Xamarin
Component: Xamarin Components ()
Version: Production (addons.xamarin.com)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jon Dick
URL:
Depends on:
Blocks:
 
Reported: 2016-05-02 00:03 UTC by Pablo Gasparini
Modified: 2017-09-28 14:50 UTC (History)
1 user (show)

Tags: mapbox, android
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Pablo Gasparini 2016-05-02 00:03:55 UTC
The android sample for the Mapbox 4.0.0 version does not compile and throws the following error:


Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: Could not find a part of the path "<projectPath>\Components\mapboxsdk-4.0.0.0\samples\MapboxSampleAndroid\MapBoxSampleAndroid\obj\Debug\__library_projects__\MapboxSDK.Android\library_project_imports\res\drawable-anydpi-v21\ic_info_outline_24dp_selected.xml"	MapboxSampleAndroid
Comment 1 Jon Dick 2016-05-11 00:33:37 UTC
Is this on Windows in Visual Studio?

If so, I suspect you are hitting a MAX_PATH issue.  Please try moving the sample to a location closer to the drive root, deleting the bin/ and obj/ folders, and trying again.

Thanks
Comment 2 Jon Dick 2017-09-28 14:50:28 UTC
I believe this is not an issue, no response received.