Bug 40757 - Xamarin.iOS build deletes all the project files
Summary: Xamarin.iOS build deletes all the project files
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.0.0 (C6)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Adrian Alonso
URL:
Depends on:
Blocks:
 
Reported: 2016-04-28 12:55 UTC by Ali
Modified: 2016-12-22 19:44 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
XamarinLogFiles.zip (7.11 KB, application/zip)
2016-05-17 13:48 UTC, Peter Heinrich
Details
VisualStudio Xamarin iOS Version (45.80 KB, image/png)
2016-05-17 13:52 UTC, Peter Heinrich
Details
Build and Run Diagnostic log file (786.84 KB, text/plain)
2016-05-19 14:19 UTC, Peter Heinrich
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Ali 2016-04-28 12:55:05 UTC
Whenever I build my xamarin.ios app in visual studio it just deletes all the project files including the .csproj file itself.
Comment 1 Ben Beckley 2016-04-28 17:19:30 UTC
Hello Ali,

Could you please provide environment information from "Help > About Microsoft Visual Studio"

Additionally, when this happens, could you please attach the logs from that session? You can obtain them by going to "Help > Xamarin > Zip Logs..."
Comment 2 Ali 2016-04-29 15:29:46 UTC
The bug magically disappeared today, but It has reoccured to me a couple of times in the past as well, in case it started to appearing again I will post those info.
Comment 3 Ben Beckley 2016-05-02 21:57:42 UTC
It sounds like this has happened to you across different versions of Xamarin.iOS. It would be helpful for tracking purposes if you could provide the build of XVS and Xamarin.iOS that you were using when this occurred.

For now, I will mark this as Not Reproducible. If you do encounter this again, please reopen the bug with the information requested in Comment 1.

Thank you!
Comment 4 Peter Heinrich 2016-05-17 13:48:31 UTC
Created attachment 16019 [details]
XamarinLogFiles.zip
Comment 5 Peter Heinrich 2016-05-17 13:52:29 UTC
Created attachment 16020 [details]
VisualStudio Xamarin iOS Version

Hi Ben,

I am able to reproduce the behavior every time.
When I try to compile my iOS project within Visual Studio every file of my project is going to be deleted. I made two attachments with the requested informations.

Best regards

Peter
Comment 6 Ben Beckley 2016-05-17 16:01:08 UTC
Hello Peter,

Thank you for providing the version data and zipped logs. I am sorry to hear that you are experiencing this issue.

Could you please attach a diagnostic build output of this problem occurring using your reproduction? This can be enabled through "Tools > Options > Projects and Solutions > Build and Run", and then setting the build verbosity to diagnostic.
Comment 7 Peter Heinrich 2016-05-19 14:19:14 UTC
Created attachment 16035 [details]
Build and Run Diagnostic log file

Hi Ben,

sorry for my delayed answer. 
I attached the Diagnostic log file.
I can reproduce the same deleting behaviour during the clean up process.

Hope you can help.

Best regards.

Peter
Comment 8 Adrian Alonso 2016-05-19 16:30:07 UTC
Hi Peter, it would be great if you could check the following extra items:

1. Can you reproduce the issue with an empty app? Or any app you can attach/upload to this bug?
2. The files are also deleted if you build the app disconnected from the Mac Server?
3. Could you please add or rename a file with an "easy to find" name and check in the build output where it's being deleted?

Thanks,
Adrian
Comment 9 Peter Heinrich 2016-05-23 08:22:44 UTC
Hi Adrian,

1.) Unfortunately I can not reproduce the issue with an empty app.

2.) After I have disconnected the connection betwenn the mac and the windows machine I can clean up and build the project without deleting the files.

Best regards

Peter
Comment 10 Peter Heinrich 2016-05-23 08:27:47 UTC
Hi Adrian,

after I could build the solution successfully I've created the connection to the mac again. In the VS output window I could see that automatically the process "clean target(s)" is started and all files are deleted after the process has finished.

Peter
Comment 13 Adrian Alonso 2016-12-22 19:44:54 UTC
Peter: please let us know if you're still able to reproduce the issue. In the meantime I will mark the bug as resolved. Thanks, Adrian