Bug 40725 - CollectionView cell position in designer is different from what is rendered in the simulator
Summary: CollectionView cell position in designer is different from what is rendered i...
Status: RESOLVED NORESPONSE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS Designer ()
Version: 4.0.0 (C6)
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-04-27 07:08 UTC by reemfz
Modified: 2017-08-10 08:20 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
screen shots (253.64 KB, application/x-zip-compressed)
2016-04-27 07:08 UTC, reemfz
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description reemfz 2016-04-27 07:08:06 UTC
Created attachment 15853 [details]
screen shots

Hi,

When I drag a Collection View Controller or a Collection View item to a View Controller in the iOS designer in Visual Studio, the position of the cell is completely different from what will actually be rendered in the simulator. I can't express how annoying and frustrating this is.

I am attaching some screen shots to show the issue. You can see that in story board the position of the cell is completely off. This gets even worst when you set the view controller to be a root of a navigation controller.

I really think this should be tagged with high severity, unless you guys can provide a workaround.

How to reproduce:

1. Launch Visual Studio
2. Open A xamarin.ios project
3. open a story board file.
4. drag a navigation controller into the scene and delete the default root controller. replace it with a collection view controller.
5. connect the root.
6. you need to implement the GetCell and GetItemCount to see the cells in the simulator. 
I also created a custom class for the cell.


My environment:

Visual Studio update 2
Xamarin 4.0.3.214

p.s: I did not try that in Xamarin Studio.
Comment 1 Adam Hartley [MSFT] 2017-07-07 12:52:13 UTC
Thanks so much for taking the time to submit this report! 

I’m unable to reproduce this issue using the latest Visual Studio 15.3 preview builds. 

Please provide us with a sample project to help us reproduce this issue.

Thanks!
Comment 2 Prashant [MSFT] 2017-08-10 08:20:00 UTC
Because we have not received a reply to our request for more information, we are marking this issue as RESOLVED→NORESPONSE. If you are still encountering this issue on the latest Visual Studio 2017 Preview version 15.3, please don’t hesitate to reopen the ticket with the requested information. 

Thanks!