Bug 4069 - Monodevelop 2.9.2: Hovering a variable does not show its current value
Summary: Monodevelop 2.9.2: Hovering a variable does not show its current value
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 2.9.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2012-03-23 09:00 UTC by René Ruppert
Modified: 2012-03-27 01:17 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description René Ruppert 2012-03-23 09:00:53 UTC
Debugger problem:

public void foo(int a, int b)
{
 int c = a + b;
}

If you debug and hover "a" or "b" inside the method (right side of assignment), you'll see the current value of a or b.
However if you hover "a" or "b" in the method's signature ("int a") it will show you that a is an integer but not the value.
Comment 1 Jeffrey Stedfast 2012-03-26 15:42:59 UTC
hmmm, this works fine in MonoDevelop 2.8.8, so I suspect it must be a bug in the new resolver.
Comment 2 Mike Krüger 2012-03-27 01:17:19 UTC
I think it has to do with the text editor resolve provider in the 2.9.2 alpha, there was one of the methods not implemented. 

I verify this working in the current version. When merging branches the debugger needs some adjustments, it still uses the old nrefactory + old infrastructure ...