Bug 40650 - No data is available for encoding 866
Summary: No data is available for encoding 866
Status: CONFIRMED
Alias: None
Product: Class Libraries
Classification: Mono
Component: mscorlib ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Future Release
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-04-23 00:05 UTC by Eugene Berdnikov
Modified: 2017-10-27 15:10 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 40650 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Eugene Berdnikov 2016-04-23 00:05:39 UTC
I have OS X 10.11.4 with Russian primary language selected. When I try to run the Xamarin Test Recorder 0.9.2.2 it shows an icon in dock and hides it immediately without any messages. When I run it from the Terminal I have an error:
> /Applications/Xamarin\ Test\ Recorder.app/Contents/MacOS/Xamarin\ Test\ Recorder
> Unhandled Exception:
> System.NotSupportedException: No data is available for encoding 866.
>   at System.Text.Encoding.GetEncoding (Int32 codepage) [0x0024f] in /private/tmp/source-mono-4.4.0/bockbuild-mono-4.4.0-branch/profiles/mono-mac-xamarin/build-root/mono-x86/external/referencesource/mscorlib/system/text/encoding.cs:554 
>   at ICSharpCode.SharpZipLib.Zip.ZipConstants.ConvertToString (System.Byte[] data, Int32 count) <0xa536850 + 0x00023> in <filename unknown>:0 
>   at ICSharpCode.SharpZipLib.Zip.ZipConstants.ConvertToStringExt (Int32 flags, System.Byte[] data) <0xa536790 + 0x00057> in <filename unknown>:0 
>   at ICSharpCode.SharpZipLib.Zip.ZipInputStream.GetNextEntry () <0xa535c28 + 0x001a3> in <filename unknown>:0 
>   at (wrapper remoting-invoke-with-check) ICSharpCode.SharpZipLib.Zip.ZipInputStream:GetNextEntry ()
>   at Xamarin.TestRecorder.Mac.MacZipHelper.Unzip (System.String zipFile, System.String target) [0x000a8] in /Users/johnl/Developer/test-recorder/Xamarin.TestRecorder.Mac/MacZipHelper.cs:14 
>   at Xamarin.TestRecorder.Mac.MaciOSDeviceTools.SetUpDeviceToolsDependencies () [0x0004b] in /Users/johnl/Developer/test-recorder/Xamarin.TestRecorder.Mac/MaciOSDeviceTools.cs:421 
>   at Xamarin.TestRecorder.Mac.MaciOSDeviceTools..ctor (ILogger logger, IPreferenceManager preferenceManager) [0x0001c] in /Users/johnl/Developer/test-recorder/Xamarin.TestRecorder.Mac/MaciOSDeviceTools.cs:37 
>   at Xamarin.TestRecorder.Mac.AppDelegate+<DidFinishLaunching>c__async0.MoveNext () [0x0008f] in /Users/johnl/Developer/test-recorder/Xamarin.TestRecorder.Mac/AppDelegate.cs:103 
> --- End of stack trace from previous location where exception was thrown ---
>   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in /private/tmp/source-mono-4.4.0/bockbuild-mono-4.4.0-branch/profiles/mono-mac-xamarin/build-root/mono-x86/external/referencesource/mscorlib/system/runtime/exceptionservices/exceptionservicescommon.cs:143 
>   at System.Runtime.CompilerServices.AsyncMethodBuilderCore.<ThrowAsync>m__0 (System.Object state) [0x00000] in /private/tmp/source-mono-4.4.0/bockbuild-mono-4.4.0-branch/profiles/mono-mac-xamarin/build-root/mono-x86/external/referencesource/mscorlib/system/runtime/compilerservices/AsyncMethodBuilder.cs:1018 
>   at AppKit.AppKitSynchronizationContext+<Post>c__AnonStorey0.<>m__0 () [0x0000c] in /Users/builder/data/lanes/2922/fa3b68c8/source/maccore/src/AppKit/AppKitSynchronizationContext.cs:17 
>   at Foundation.NSAsyncActionDispatcher.Apply () [0x00008] in /Users/builder/data/lanes/2922/fa3b68c8/source/maccore/src/Foundation/NSAction.cs:163 
>   at (wrapper managed-to-native) AppKit.NSApplication:NSApplicationMain (int,string[])
>   at AppKit.NSApplication.Main (System.String[] args) [0x00041] in /Users/builder/data/lanes/2922/fa3b68c8/source/maccore/src/AppKit/NSApplication.cs:94 
>   at Xamarin.TestRecorder.Mac.MainClass.Main (System.String[] args) [0x00008] in /Users/johnl/Developer/test-recorder/Xamarin.TestRecorder.Mac/Main.cs:15 
> [ERROR] FATAL UNHANDLED EXCEPTION: System.NotSupportedException: No data is available for encoding 866.
>   at System.Text.Encoding.GetEncoding (Int32 codepage) [0x0024f] in /private/tmp/source-mono-4.4.0/bockbuild-mono-4.4.0-branch/profiles/mono-mac-xamarin/build-root/mono-x86/external/referencesource/mscorlib/system/text/encoding.cs:554 
>   at ICSharpCode.SharpZipLib.Zip.ZipConstants.ConvertToString (System.Byte[] data, Int32 count) <0xa536850 + 0x00023> in <filename unknown>:0 
>   at ICSharpCode.SharpZipLib.Zip.ZipConstants.ConvertToStringExt (Int32 flags, System.Byte[] data) <0xa536790 + 0x00057> in <filename unknown>:0 
>   at ICSharpCode.SharpZipLib.Zip.ZipInputStream.GetNextEntry () <0xa535c28 + 0x001a3> in <filename unknown>:0 
>   at (wrapper remoting-invoke-with-check) ICSharpCode.SharpZipLib.Zip.ZipInputStream:GetNextEntry ()
>   at Xamarin.TestRecorder.Mac.MacZipHelper.Unzip (System.String zipFile, System.String target) [0x000a8] in /Users/johnl/Developer/test-recorder/Xamarin.TestRecorder.Mac/MacZipHelper.cs:14 
>   at Xamarin.TestRecorder.Mac.MaciOSDeviceTools.SetUpDeviceToolsDependencies () [0x0004b] in /Users/johnl/Developer/test-recorder/Xamarin.TestRecorder.Mac/MaciOSDeviceTools.cs:421 
>   at Xamarin.TestRecorder.Mac.MaciOSDeviceTools..ctor (ILogger logger, IPreferenceManager preferenceManager) [0x0001c] in /Users/johnl/Developer/test-recorder/Xamarin.TestRecorder.Mac/MaciOSDeviceTools.cs:37 
>   at Xamarin.TestRecorder.Mac.AppDelegate+<DidFinishLaunching>c__async0.MoveNext () [0x0008f] in /Users/johnl/Developer/test-recorder/Xamarin.TestRecorder.Mac/AppDelegate.cs:103 
> --- End of stack trace from previous location where exception was thrown ---
>   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in /private/tmp/source-mono-4.4.0/bockbuild-mono-4.4.0-branch/profiles/mono-mac-xamarin/build-root/mono-x86/external/referencesource/mscorlib/system/runtime/exceptionservices/exceptionservicescommon.cs:143 
>   at System.Runtime.CompilerServices.AsyncMethodBuilderCore.<ThrowAsync>m__0 (System.Object state) [0x00000] in /private/tmp/source-mono-4.4.0/bockbuild-mono-4.4.0-branch/profiles/mono-mac-xamarin/build-root/mono-x86/external/referencesource/mscorlib/system/runtime/compilerservices/AsyncMethodBuilder.cs:1018 
>   at AppKit.AppKitSynchronizationContext+<Post>c__AnonStorey0.<>m__0 () [0x0000c] in /Users/builder/data/lanes/2922/fa3b68c8/source/maccore/src/AppKit/AppKitSynchronizationContext.cs:17 
>   at Foundation.NSAsyncActionDispatcher.Apply () [0x00008] in /Users/builder/data/lanes/2922/fa3b68c8/source/maccore/src/Foundation/NSAction.cs:163 
>   at (wrapper managed-to-native) AppKit.NSApplication:NSApplicationMain (int,string[])
>   at AppKit.NSApplication.Main (System.String[] args) [0x00041] in /Users/builder/data/lanes/2922/fa3b68c8/source/maccore/src/AppKit/NSApplication.cs:94 
>   at Xamarin.TestRecorder.Mac.MainClass.Main (System.String[] args) [0x00008] in /Users/johnl/Developer/test-recorder/Xamarin.TestRecorder.Mac/Main.cs:15

It runs correctly after I switched the primary language to English.
Comment 2 Joshua Escribano 2016-04-25 15:11:04 UTC
Could you also include the command line output from running the "locale" command in the terminal?
Thanks!
Joshua
Comment 3 Eugene Berdnikov 2016-04-26 23:21:09 UTC
Both, Build1 and Build2 run correctly, thanks!
Here is output of the locale command after switching back to Russian:
> locale
> LANG="ru_RU.UTF-8"
> LC_COLLATE="ru_RU.UTF-8"
> LC_CTYPE="ru_RU.UTF-8"
> LC_MESSAGES="ru_RU.UTF-8"
> LC_MONETARY="ru_RU.UTF-8"
> LC_NUMERIC="ru_RU.UTF-8"
> LC_TIME="ru_RU.UTF-8"
> LC_ALL=