Bug 40614 - V0.32 Profiler does not run at all on Windows 8.1
Summary: V0.32 Profiler does not run at all on Windows 8.1
Status: RESOLVED ANSWERED
Alias: None
Product: Profiler
Classification: Xamarin
Component: General ()
Version: 0.32.x
Hardware: PC Windows
: High normal
Target Milestone: (C8)
Assignee: Jose Miguel Torres
URL:
Depends on:
Blocks:
 
Reported: 2016-04-21 16:03 UTC by FieldstrikeMobile
Modified: 2016-05-12 19:27 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description FieldstrikeMobile 2016-04-21 16:03:01 UTC
If I click the profiler application it does not open. checking the event logs of my computer I can see the following:

Application: XamarinProfiler.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.IO.FileNotFoundException
   at XamarinProfiler.Windows.App..ctor()
   at XamarinProfiler.Windows.App.Main()


Faulting application name: XamarinProfiler.exe, version: 0.32.0.0, time stamp: 0x56d41be6
Faulting module name: KERNELBASE.dll, version: 6.3.9600.18264, time stamp: 0x56e1bd71
Exception code: 0xe0434352
Fault offset: 0x0000000000008a5c
Faulting process ID: 0x20c8
Faulting application start time: 0x01d19be4f13df091
Faulting application path: C:\Program Files (x86)\Xamarin\Profiler\XamarinProfiler.exe
Faulting module path: C:\WINDOWS\system32\KERNELBASE.dll
Report ID: 2f0d06c9-07d8-11e6-bfc1-7054d2ab6eb2
Faulting package full name: 
Faulting package-relative application ID:
Comment 1 FieldstrikeMobile 2016-04-21 16:05:01 UTC
downgrading to version 0.24 (my previous version I had installed) fixes the issue
Comment 2 FieldstrikeMobile 2016-04-21 16:19:47 UTC
could be linked to http://forums.xamarin.com/discussion/comment/187360/#Comment_187360

as I am running Xamarin.Studio V5.10.3 ( build 51)
Comment 3 Jose Miguel Torres 2016-05-12 19:27:40 UTC
This is a known issue. After 0.24 we have to either uninstall 0.24 before installing 0.32 or once 0.32 is installed and it does not work, repair the installation.