Bug 40479 - Build fails in Xamarin Studio 6 - unhelpful error message
Summary: Build fails in Xamarin Studio 6 - unhelpful error message
Status: RESOLVED DUPLICATE of bug 37977
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 6.0.0 (C7)
Hardware: PC Windows
: --- normal
Target Milestone: (C7)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-04-18 10:48 UTC by Lewis Westbury
Modified: 2016-05-09 07:54 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
IDE log (271.25 KB, text/plain)
2016-04-18 15:37 UTC, Lewis Westbury
Details
.NET 4.5.1 already installed (11.28 KB, image/png)
2016-04-18 16:00 UTC, Lewis Westbury
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 37977

Description Lewis Westbury 2016-04-18 10:48:25 UTC
Description of Problem:

On load of a solution in Xamarin Studio 6.0 (build 4968), the source is instantly littered with red-underline errors. None of the projects will build, and the error reported is: "Build failed. See the build log for details." The build output doesn't contain anything more.

Steps to reproduce the problem:
1. Upgrade to Xamarin Studio 6.0 in the beta channel.
2. Open an existing solution.
3. Attempt to build.

Actual Results:

The code is littered with error markers (red-underline), and builds fail immediately with the error "Build failed. See the build log for details." The build output simply shows:
"Build failed.
Build: 1 error, 0 warnings"

Expected Results:

Either, the code compiles (as it did before the upgrade), or at the very least the build output contains an error message indicating what went wrong (and therefore what I can do to fix it!) I appreciate that XS 6.0 is in beta, so I'm happy to go the extra mile, but would be good to have an inkling of what failed...

How often does this happen? 

Reliably every time.

Additional Information:

During installation, Xamarin Studio installer insisted that MS Build Tools 2013. I first tried to install MS Build Tools 2015, hoping this would be sufficient (and yet at the same time better and more recent). It was no good, so I then installed MS Build Tools 2013. The upgrade then completed succesfully, although afterwards this bug became apparent.
Comment 1 Lewis Westbury 2016-04-18 10:49:12 UTC
Opened a thread about it in the forums for any other users encountering the same:
http://forums.xamarin.com/discussion/64916/build-tools-2013?new=1
Comment 2 Lewis Westbury 2016-04-18 10:50:00 UTC
Xamarin Studio Indie
Version 6.0 (build 4968)
Installation UUID: 39e1bf39-ddc3-40ac-b5dc-fb44474be399
Runtime:
	Microsoft .NET 4.0.30319.42000
	GTK+ 2.24.26 (Light theme)
	GTK# 2.12.33

Xamarin.Profiler
Not Installed

Xamarin.Android
Version: 6.1.0.37 (Xamarin Indie)
Android SDK: C:\Users\Lewis Westbury\AppData\Local\Android\android-sdk
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.3   (API level 18)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.1.0 rc1
SDK Build Tools Version: 23.0.2

Java SDK: C:\Program Files (x86)\Java\jdk1.7.0_71
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) Client VM (build 24.71-b01, mixed mode, sharing)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

Xamarin Android Player
Version: 0.6.5
Location: C:\Program Files\Xamarin Android Player\DeviceManager.exe

Build Information
Release ID: 600004968
Git revision: ab7092ce63351276394f283e4f9c8646baf51fce
Build date: 2016-04-08 09:20:36-04
Xamarin addins: be0a0aef6ec8b075b4ba4690bd147d1e33c2abd7
Build lane: monodevelop-windows-cycle7

Operating System
Windows 10.0.10586.0 (64-bit)
Comment 3 Lewis Westbury 2016-04-18 10:54:22 UTC
All build operations seem to fail (including Clean).
Comment 4 Lewis Westbury 2016-04-18 10:56:09 UTC
Even CLR constructs (string, bool, Guid, etc.) are showing the red error underlines with popover, eg. "Error: Predefined type 'System.String' is not defined for imported"
Comment 5 Matt Ward 2016-04-18 15:14:48 UTC
Can you attach the IDE logs? Help - Open Log Directory.
Comment 6 Lewis Westbury 2016-04-18 15:37:03 UTC
Created attachment 15752 [details]
IDE log
Comment 7 Lewis Westbury 2016-04-18 16:00:43 UTC
Created attachment 15753 [details]
.NET 4.5.1 already installed

Just to confirm, based on the content of the IDE log, I attempted to install .NET 4.5.1. It reports that it cannot install as the .NET framework 4.5 is already installed.
Comment 8 Lewis Westbury 2016-05-04 12:26:57 UTC
It seems that the solution to this bug is that Xamarin Studio is no longer available for Windows! Prepare to move over to Visual Studio.

A question remains as to what I'm currently paying for now, but I'll raise that through other channels ;)
Comment 9 Andres G. Aragoneses 2016-05-07 10:57:16 UTC
From the log:

System.InvalidOperationException: No compatible framework found for assembly 'C:\Program Files (x86)\Xamarin Studio\bin\MSBuild\dotnet.14.0\MonoDevelop.Projects.Formats.MSBuild.exe' (required framework: .NETFramework,Version=v4.5.1)

This is exactly same error as reported in bug 37977 so I guess this is a duplicate.
Comment 10 Lluis Sanchez 2016-05-09 07:54:16 UTC

*** This bug has been marked as a duplicate of bug 37977 ***