Bug 40378 - Page OnDisappearing not firing after using media picker
Summary: Page OnDisappearing not firing after using media picker
Status: CONFIRMED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 2.2.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-04-14 02:50 UTC by Tristan
Modified: 2016-04-20 15:14 UTC (History)
2 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 40378 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Tristan 2016-04-14 02:50:42 UTC
I have a master detail navigation page which pushes a standard content page. On the content page I display an action sheet which allows me to take a photo using James Montemagno plugin "Plugin.Media.CrossMedia.Current.TakePhotoAsync".

As soon as the take picture modal is pushed, the content page receives the OnDisappearingEvent. Once I have taken the picture, I am returned to the content page where I can use it as normal (push buttons etc). Once I dismiss this content page with the back button, I do not receive the OnDisappearing event.

The OnDisappearing event fires for iOS.

id="Xamarin.Forms" version="2.1.0.6529" targetFramework="MonoAndroid60"