Bug 4027 - [newresolver] var variables don't offer full completion
Summary: [newresolver] var variables don't offer full completion
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: Trunk
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2012-03-22 09:07 UTC by Marek Habersack
Modified: 2012-03-27 01:34 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Marek Habersack 2012-03-22 09:07:45 UTC
In the sample below replacing 'var l' with full type declaration makes completion work:

void Method ()
{
  var l = new List <string> ();

  l. // <- no completion offered (or only extension methods local to the project)
}

another instance which doesn't work for me is

void Method ()
{
   List <Tuple <string, string>> urls;

   foreach (string url in SomeCollection) {
      urls = DoSomething (url);
      urls. // <- same behavior as in the sample below
   }
}
Comment 1 Mike Krüger 2012-03-23 04:35:07 UTC
Can't verify the bug. We had some resolver issues this week - but got fixed.

Do you have the bug with todays build ?
Comment 2 Mike Krüger 2012-03-27 01:34:03 UTC
I think it had to do with the typesystem update bugs I fixed last week. Reopen, if it happens again.