Bug 40257 - Building 64-bit Mono on OS X 10.11.4 gives "[libmonoruntime_la-threads.lo] Error 1"
Summary: Building 64-bit Mono on OS X 10.11.4 gives "[libmonoruntime_la-threads.lo] Er...
Status: RESOLVED NORESPONSE
Alias: None
Product: Runtime
Classification: Mono
Component: packaging ()
Version: 4.2.0 (C6)
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Alexis Christoforides
URL:
Depends on:
Blocks:
 
Reported: 2016-04-09 20:48 UTC by Dimitar Dobrev
Modified: 2016-08-29 09:16 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Dimitar Dobrev 2016-04-09 20:48:20 UTC
I have been trying to build Mono 4.2.3 on OS X 10.11.4. It fails with the following error:

[libmonoruntime_la-threads.lo] Error 1

I use the source package from:

http://download.mono-project.com/sources/mono/mono-4.2.3.4.tar.bz2

Following the instructions at http://www.mono-project.com/docs/compiling-mono/mac/, I configure with:

./configure --prefix=/Library/Frameworks/Mono.framework/Versions/4.2.3 --disable-nls

The binary installers do not work for me because I need the combined 32/64-bit Mono as per https://github.com/Monobjc/mono-macosx-64/wiki.
Comment 1 Rodrigo Kumpera 2016-04-14 06:20:19 UTC
Run "make V=1", this will print mode detailed output of what's going on.

That might be enough to help you troubleshoot your problem, otherwise paste it here.

Mono 4.4 ships lipo'd 32 and 64 binaries, you should consider using it.
Comment 2 Alex Rønne Petersen 2016-08-29 09:16:00 UTC
Since there has been no activity on this bug for several months, I'm going to close it. If you still have issues building Mono, feel free to reopen with more information (specifically, a full build log with `make V=1` would be helpful). Thanks!