Bug 40066 - FormattedString does not work on UWP
Summary: FormattedString does not work on UWP
Status: RESOLVED INVALID
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.2.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-04-02 15:45 UTC by Ray Kelly
Modified: 2016-04-06 14:05 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Ray Kelly 2016-04-02 15:45:52 UTC
FormatedString works fine on all platforms except for Windows Universal.   Nothing is displayed when a Label is bound to a FormattedString variable:

XAML
<Label FormattedText="{Binding FormattedMessage}" FontSize="14"/>

Again, works find under iOS, Android and Windows Phone.
Comment 1 Samantha Houts [MSFT] 2016-04-05 17:25:01 UTC
Thank you for taking the time to submit the bug. We tried to reproduce the issue you reported but were unable given the description. If you could please attach a reproduction to the bug by starting with a clean Xamarin.Forms project and adding just the code necessary to demonstrate the issue, we would very much appreciate it. 


For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d

Warm regards,
Xamarin Forms Team
Comment 2 Ray Kelly 2016-04-06 14:05:59 UTC
Sorry, this is caused by a different issue.  When using FormattedString, nothing is shown unless you also assign the Text property of the label.  This same code fixes the issue:

<Label Text="" FormattedText="{Binding FormattedMessage}" FontSize="14"/>

I will need to repopen another but with proper title.  Thanks.