Bug 4005 - Opening serial port > COM10
Summary: Opening serial port > COM10
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System ()
Version: 2.10.x
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-03-21 05:47 UTC by koenraad.vandeneeckhout
Modified: 2012-05-14 02:09 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description koenraad.vandeneeckhout 2012-03-21 05:47:17 UTC
Running on Mono 2.10.8, windows XP

using System.IO.Ports;

SerialPort m_port = new SerialPort("COM10");
m_port.Open();

or

SerialPort m_port = new SerialPort();
m_port.PortName = "COM10";
m_port.Open();

Both these code snippets throws a System.IO.IOException: "The port `COM10' does not exist."
This happens for every COM port > COM10.
The following code works:

SerialPort m_port = new SerialPort(@"\\.\COM10");
m_port.Open();

but:

SerialPort m_port = new SerialPort();
m_port.PortName = @"\\.\COM10";
m_port.Open();

also does not work, throwing a System.ArgumentException.
Comment 1 Konrad Kruczyński 2012-05-12 13:48:36 UTC
Shouldn't this be closed because of https://github.com/mono/mono/commit/caadb775079bda48e9ada535c64662a26366f6b6?
Comment 2 koenraad.vandeneeckhout 2012-05-14 02:09:11 UTC
Indeed. Status changed to fixed