Bug 40012 - Didn't find class "mono.android.app.Application"
Summary: Didn't find class "mono.android.app.Application"
Status: RESOLVED NORESPONSE
Alias: None
Product: Android
Classification: Xamarin
Component: Debugger ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-03-31 07:33 UTC by klark
Modified: 2017-09-09 08:36 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
build info (1.17 MB, text/plain)
2016-03-31 07:33 UTC, klark
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description klark 2016-03-31 07:33:05 UTC
Created attachment 15567 [details]
build info

My APP fails to start!With the following information:

Forwarding debugger port 8824
Detecting existing process
[AndroidRuntime] Shutting down VM
[AndroidRuntime] FATAL EXCEPTION: main
[AndroidRuntime] Process: AnXinMe.RemoteTv.Droid, PID: 21244
[AndroidRuntime] java.lang.RuntimeException: Unable to instantiate application mono.android.app.Application: java.lang.ClassNotFoundException: Didn't find class "mono.android.app.Application" on path: DexPathList[[zip file "/data/app/AnXinMe.RemoteTv.Droid-1.apk"],nativeLibraryDirectories=[/data/app-lib/AnXinMe.RemoteTv.Droid-1, /vendor/lib, /system/lib]]
[AndroidRuntime] 	at android.app.LoadedApk.makeApplication(LoadedApk.java:509)
[AndroidRuntime] 	at android.app.ActivityThread.handleBindApplication(ActivityThread.java:4427)
[AndroidRuntime] 	at android.app.ActivityThread.access$1500(ActivityThread.java:147)
[AndroidRuntime] 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1271)
[AndroidRuntime] 	at android.os.Handler.dispatchMessage(Handler.java:102)
[AndroidRuntime] 	at android.os.Looper.loop(Looper.java:136)
[AndroidRuntime] 	at android.app.ActivityThread.main(ActivityThread.java:5135)
[AndroidRuntime] 	at java.lang.reflect.Method.invokeNative(Native Method)
[AndroidRuntime] 	at java.lang.reflect.Method.invoke(Method.java:515)
[AndroidRuntime] 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:795)
[AndroidRuntime] 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:611)
[AndroidRuntime] 	at dalvik.system.NativeStart.main(Native Method)
[AndroidRuntime] Caused by: java.lang.ClassNotFoundException: Didn't find class "mono.android.app.Application" on path: DexPathList[[zip file "/data/app/AnXinMe.RemoteTv.Droid-1.apk"],nativeLibraryDirectories=[/data/app-lib/AnXinMe.RemoteTv.Droid-1, /vendor/lib, /system/lib]]
[AndroidRuntime] 	at dalvik.system.BaseDexClassLoader.findClass(BaseDexClassLoader.java:56)
[AndroidRuntime] 	at java.lang.ClassLoader.loadClass(ClassLoader.java:497)
[AndroidRuntime] 	at java.lang.ClassLoader.loadClass(ClassLoader.java:457)
[AndroidRuntime] 	at android.app.Instrumentation.newApplication(Instrumentation.java:975)
[AndroidRuntime] 	at android.app.LoadedApk.makeApplication(LoadedApk.java:504)
[AndroidRuntime] 	... 11 more
[Process] Sending signal. PID: 21244 SIG: 9
Comment 1 Prashant [MSFT] 2017-06-29 04:46:19 UTC
Thank you for taking the time to submit the bug. We are unable to reproduce this issue. Please attach a reproduction to the bug by starting with a clean Xamarin.Android project and adding just the code necessary to demonstrate the issue.
Comment 2 Cody Beyer (MSFT) 2017-08-23 20:35:34 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!
Comment 3 softlion 2017-09-09 08:36:15 UTC
Duplicate of https://bugzilla.xamarin.com/show_bug.cgi?id=55268