Bug 40005 - [Android] Navigation Bar back button does not show when using InsertPageBefore(insertedPage, page1) to add a page to the stack before the first page.
Summary: [Android] Navigation Bar back button does not show when using InsertPageBefor...
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 2.1.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-03-30 22:35 UTC by Jon Goldberger [MSFT]
Modified: 2016-06-29 19:03 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test Project (50.33 KB, application/zip)
2016-03-30 22:35 UTC, Jon Goldberger [MSFT]
Details
Updated Test Project (50.35 KB, application/zip)
2016-03-30 22:52 UTC, Jon Goldberger [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Jon Goldberger [MSFT] 2016-03-30 22:35:12 UTC
Created attachment 15563 [details]
Test Project

## Description

Navigation Bar back button does not show when using InsertPageBefore(insertedPage, page1) to add a page to the stack before the first page, page1. It does, however, show on page1 after navigating to page2 and back. 

Also pressing the hardware back button does take you back to the inserted page. 

Issue does not occur on iOS, the Nav Bar Back button is displayed after inserting a page with  InsertPageBefore.

## Steps to reproduce

1. Open the attached test project and deploy Android project to a device or simulator (Tested with XAP Nexus 5 (Lollipop))

Expected result: the Navigation bar back button will show.

Actual result: No navigation bar back button is displayed. 

## Environment

Forms version: 2.1.0.6529

=== Xamarin Studio ===

Version 5.10.3 (build 27)
Installation UUID: 964c531b-d928-456b-a9ae-e1f82266b360
Runtime:
	Mono 4.2.3 (explicit/832de4b)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402030004

=== Xamarin.Profiler ===

Version: 0.32.0
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 7.3 (10183.3)
Build 7D175

=== Xamarin.iOS ===

Version: 9.6.0.0 (Business Edition)
Hash: d7cac50
Branch: master
Build date: 2016-03-21 20:13:04-0400

=== Xamarin.Android ===

Version: 6.0.2.1 (Business Edition)
Android SDK: /Users/apple/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.1
SDK Build Tools Version: 23.0.3

Java SDK: /usr
java version "1.7.0_79"
Java(TM) SE Runtime Environment (build 1.7.0_79-b15)
Java HotSpot(TM) 64-Bit Server VM (build 24.79-b02, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.4.1.7 (Business Edition)

=== Xamarin Inspector ===

Version: 0.5.0.0
Hash: 45b35bb
Branch: master
Build date: Thu Jan 14 18:53:32 UTC 2016

=== Build Information ===

Release ID: 510030027
Git revision: 8dc6bca63f5cd93719a093973e74de6999864193
Build date: 2016-03-17 17:13:33-04
Xamarin addins: 45239909442742bdee83a0c0f77eecb8a08bedfa
Build lane: monodevelop-lion-cycle6-c6sr2

=== Operating System ===

Mac OS X 10.11.4
Darwin Jons-iMac.local 15.4.0 Darwin Kernel Version 15.4.0
    Fri Feb 26 22:08:05 PST 2016
    root:xnu-3248.40.184~3/RELEASE_X86_64 x86_64
Comment 2 Jon Goldberger [MSFT] 2016-03-30 22:52:00 UTC
Created attachment 15564 [details]
Updated Test Project
Comment 3 Rui Marinho 2016-05-13 15:13:09 UTC
Hi Jon this is fixed if you use the FormsAppCompatActivity
Comment 4 Rui Marinho 2016-05-13 15:31:55 UTC
Hi, btw i added a fix for non FormsAppCompact too, should be in  the next release.
Comment 5 Rui Marinho 2016-05-13 16:02:44 UTC
PR up https://github.com/xamarin/Xamarin.Forms/pull/173
Comment 6 Rui Marinho 2016-05-27 11:24:47 UTC
Should be fixed in 2.3.1-pre1
Comment 7 Parmendra Kumar 2016-06-29 19:03:15 UTC
I have checked this issue with Xamarin.Forms 2.3.1-pre1 and Its working fine at my end.

Hence closing this issue.