Bug 39986 - broken installation on Debian/ubuntu
Summary: broken installation on Debian/ubuntu
Status: RESOLVED FIXED
Alias: None
Product: Installers
Classification: Mono
Component: General ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Jo Shields
URL:
Depends on:
Blocks:
 
Reported: 2016-03-30 00:46 UTC by rotrevrep
Modified: 2016-09-20 18:44 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description rotrevrep 2016-03-30 00:46:21 UTC
libmono-* packages from your repositories are broken because 'libmono-2.0.so' link is missing, so 'mono-2' pc file can't retrieve -lmono-2.0 library
Comment 1 Rodrigo Kumpera 2016-03-30 15:15:29 UTC
Hey Jo,

Could you take a look at this one?
Comment 2 Jo Shields 2016-03-30 15:21:13 UTC
libmono-2.0-dev package. Hasn't gone anywhere!

directhex@ip-10-197-40-105:/srv/www/htdocs/ftp.novell.com/pub/mono/repo/debian/pool/main/m/mono$ dpkg -c libmono-2.0-dev_4.4.0.40-0xamarin1_amd64.deb | grep so$
lrwxrwxrwx root/root         0 2016-03-16 17:08 ./usr/lib/libmono-2.0.so -> libmonosgen-2.0.so
Comment 3 rotrevrep 2016-03-30 20:29:41 UTC
@Jo no. 'from -> to' is the textual representation of symlink. libmonosgen-2.0.so is present in libmonosgen-2.0-dev package, not in libmono-2.0-dev. libmono-2.0-dev doesn't install libmonosgen-2.0-dev
Comment 4 rotrevrep 2016-03-30 20:33:01 UTC
for next updates, please add libmonosgen-2.0-dev to debian control ;)
Comment 5 Jo Shields 2016-03-30 20:42:31 UTC
Aha!

The issue is the default runtime changed in the 4.4 branch (hence the symlink changed), but the package still depends on Boehm, not SGen.

Fixed in git.

Relevant Mono commit is 2324a7ad9, packaging commit is 9d7e6217
Comment 6 rotrevrep 2016-03-30 21:58:10 UTC
thanks.