Bug 39985 - Mono 4.4.0.40 alpha on Windows crashes when invoking "mcs --version"
Summary: Mono 4.4.0.40 alpha on Windows crashes when invoking "mcs --version"
Status: VERIFIED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: General ()
Version: unspecified
Hardware: PC Windows
: --- major
Target Milestone: (C7)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-03-29 23:53 UTC by Alexander Köplinger [MSFT]
Modified: 2016-06-02 06:06 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Alexander Köplinger [MSFT] 2016-03-29 23:53:39 UTC
Steps:

1. Download and install C7 Mono for Windows alpha from http://www.mono-project.com/download/alpha/#download-win
2. Open Mono Command Prompt
3. Run "mcs --version". It crashes with a heap corruption error (unfortunately I don't have more details as I don't have a Windows dev setup right now).

You may need to run step 3 a couple times as it doesn't always crash. I strongly suspect this is also what's taking out most of our Windows builds on Jenkins since we updated to the alpha.
Comment 1 Zoltan Varga 2016-03-30 19:18:05 UTC
This might have fixed it:
https://github.com/mono/mono/commit/d38c887328ff2c35f45abadfad0bab5212764f66
Comment 2 Alexander Köplinger [MSFT] 2016-03-31 14:04:03 UTC
I built the latest tip of the mono-4.4.0-branch and it doesn't repro there, so looks like that's it. Thanks!
Comment 3 Saurabh 2016-06-02 06:06:25 UTC
I have checked this Issue with latest Mono downloaded from http://www.mono-project.com/download/alpha/#download-win

I am successfully able to see version using command mcs --version.

Mono version 4.4.0
Prepending 'C:\Program Files\Mono\bin\' to PATH

C:\Program Files\Mono>mcs --version
Mono C# compiler version 4.4.0.0

C:\Program Files\Mono>mcs --version
Mono C# compiler version 4.4.0.0

C:\Program Files\Mono>mcs --version
Mono C# compiler version 4.4.0.0

C:\Program Files\Mono>mcs --version
Mono C# compiler version 4.4.0.0

C:\Program Files\Mono>mcs --version
Mono C# compiler version 4.4.0.0

C:\Program Files\Mono>mcs --version
Mono C# compiler version 4.4.0.0

C:\Program Files\Mono>mcs --version
Mono C# compiler version 4.4.0.0

C:\Program Files\Mono>mcs --version
Mono C# compiler version 4.4.0.0

C:\Program Files\Mono>mcs --version
Mono C# compiler version 4.4.0.0

C:\Program Files\Mono>mcs --version
Mono C# compiler version 4.4.0.0

C:\Program Files\Mono>mcs --version
Mono C# compiler version 4.4.0.0

C:\Program Files\Mono>mcs --version
Mono C# compiler version 4.4.0.0

I am not seeing any crash. Hence, closing this Issue.