Bug 39962 - Reason: System.UnauthorizedAccessException: Access to the path "C:\Users\Niklas Österlund" is denied.
Summary: Reason: System.UnauthorizedAccessException: Access to the path "C:\Users\Nikl...
Status: RESOLVED DUPLICATE of bug 24868
Alias: None
Product: Components
Classification: Xamarin
Component: Xamarin Components ()
Version: Staging (addons.xamstage.com)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bill Holmes
URL:
Depends on:
Blocks:
 
Reported: 2016-03-29 08:42 UTC by Niklas Österlund
Modified: 2016-07-08 10:41 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 24868

Description Niklas Österlund 2016-03-29 08:42:24 UTC
The real path on my computer is "C:\Users\Niklas Österlund" but it seems that it can't read extended ascii characters.

Reason: System.UnauthorizedAccessException: Access to the path "C:\Users\Niklas Österlund" is denied.
Comment 1 Matt Ward 2016-03-29 09:47:56 UTC
This happens when you are installing a component?

Can you attach the IDE and Component logs to this bug? (Help - Open Log Directory).
Comment 2 Léopold Baillard 2016-07-08 08:21:31 UTC
As the original poster did not answer, I'd like to contribute. My user folder path is "C:\Users\Léo" and I have the same problem.

Seems like encoding would be an issue here. Sadly, the error does not come up in the logs you mentioned. Must be somewhere else.

The error message in VS (2015) reads:
"Erreur		Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: System.UnauthorizedAccessException: Access to the path "C:\Users\L├®o" is denied.	MyTunes.Droid"
Comment 3 Matt Ward 2016-07-08 10:20:27 UTC
@Léopold - This happens when installing the component or building the project? Just trying to see what the steps are to reproduce this problem.
Comment 4 Léopold Baillard 2016-07-08 10:25:11 UTC
When building the project.
Comment 5 Matt Ward 2016-07-08 10:41:20 UTC
I am guessing that this is an Android project since you are on Windows. This seems to be a problem with the Android build. There are some other reports logged for this such as bug #19324 or #24868

*** This bug has been marked as a duplicate of bug 24868 ***