Bug 3976 - MonoTouch.Dialog: Block rendering of StyledStringElement
Summary: MonoTouch.Dialog: Block rendering of StyledStringElement
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 5.2
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-03-19 14:33 UTC by Ian
Modified: 2012-04-11 09:24 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
blocks (72.08 KB, image/jpeg)
2012-03-19 14:33 UTC, Ian
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Ian 2012-03-19 14:33:46 UTC
Created attachment 1542 [details]
blocks

In the attached image you can see that in a StyleStringElement in a list, when scrolled quickly the title renders black. If I rotate the ipad the list re-renders and is fine. I can also call .ReloadData() to cause the block render to 'clear'.

Is there a work around?

Ref: http://stackoverflow.com/questions/9747616/monotouch-monotouch-dialog-rendering-titles

and

http://stackoverflow.com/questions/9456650/weird-blocks-when-adding-elements-to-monotouch-dialog-rootelement-after-it-is-sh
Comment 1 Rolf Bjarne Kvinge [MSFT] 2012-04-11 09:24:55 UTC
Fixed in master (518142b). The fix will be included in 5.3.3.

The workaround is to call .ReloadData after adding the new StyleStringElements.