Bug 39686 - iOS Visual Studio integration breaks often unless continuously developing
Summary: iOS Visual Studio integration breaks often unless continuously developing
Status: RESOLVED ANSWERED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: unspecified
Hardware: PC Mac OS
: --- major
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-03-16 17:03 UTC by achung
Modified: 2016-04-14 13:01 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description achung 2016-03-16 17:03:30 UTC
Regarding technical issues, the biggest time wasters are build issues for iOS. We use MSBuild for our build process and the iOS Visual Studio integration seems to break often unless you are continuously developing with iOS and keeping all the tools up to date. I attempted to update to Xamarin 4 but had to rollback due to compatibility/build issues that I did not have time to resolve. Considering my dependency on MSBuild I am often concerned that new updates will break any integration that I was previously able to implement.

RE: the specifics around the issue:
The issue is difficult to nail down, on one repo/branch it is able to build fine, while in another Visual Studio complains about a Build Host version mismatch even though the project files should be the same in both.


               Xamarin: 3.11.1594
                Xamarin.iOS (VS): 9.1.0.0
                Xamarin.iOS (Mac): 9.1.0.31
                Xamarin Build host: 3.11.0.1593
Comment 1 Jose Gallardo 2016-04-14 13:01:06 UTC
Hey Andrew,

XamarinVS 4 included a significant major change on how Xamarin connects from Windows to Mac, which was the Xamarin Mac Agent (XMA) using SSH instead of the old Build Host approach.(https://developer.xamarin.com/releases/vs/xamarin.vs_4/xamarin.vs_4.0/#Xamarin_Mac_Agent)

That was a needed breaking change, as it enabled tons of improvements on our product.

After that change, which requires a different setup on the Mac (Enabling Remote Login) and in your build script (as it requires Mac credentials), newer builds shouldn't break anything in that place.

In XVS 4.1 (current Beta) we are also supporting command line builds connecting to the Mac using parametrized SSH Key authentication, including passphrase. If that setup fits better your case please let me know.

One thing we cannot resolve (yet) is that Windows and Mac needs to be updated to the same compatible version simultaneously, However, starting with XVS 4, we're allowing to build it successfully even without updating Windows (unless the changes on the x.iOS Build system make it to fail).

I agree this is an issue moving from XVS 3 to XVS 4, and it used to be an annoying issue with the old Build Host (XVS 3 and older versions), but starting from XVS 4 I think this scenario has been improved significantly.

Thanks!

-j