Bug 39631 - PPDB support fails to load any pdb when verifier is involved
Summary: PPDB support fails to load any pdb when verifier is involved
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2016-03-15 09:09 UTC by Marek Safar
Modified: 2016-03-23 21:14 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
system.pdb (1.04 MB, application/octet-stream)
2016-03-15 09:27 UTC, Marek Safar
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Marek Safar 2016-03-15 09:09:00 UTC
The only error message I get is

Could not load image foo.pdb due to CLI header missing
Comment 1 Zoltan Varga 2016-03-15 09:24:24 UTC
I can't reproduce this, could you attach a .exe/.pdb which fails ?
Comment 2 Marek Safar 2016-03-15 09:27:53 UTC
Created attachment 15403 [details]
system.pdb
Comment 3 Zoltan Varga 2016-03-15 09:40:03 UTC
I copied it next to System.dll, and run a process test using
mono --debug process.exe,
and the file was loaded successfully.
Comment 4 Marek Safar 2016-03-15 09:47:14 UTC
Updated the description, the failure happens when you run mono with "--verify-all"
Comment 5 Zoltan Varga 2016-03-23 21:14:53 UTC
Disabled the verifier for ppdb files for now.