Bug 39553 - [Papercut] Mac Agent does not detect/message if Xamarin.iOS is not installed on the Mac
Summary: [Papercut] Mac Agent does not detect/message if Xamarin.iOS is not installed ...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: XMA ()
Version: 4.0.0 (C6)
Hardware: PC Mac OS
: Normal normal
Target Milestone: 15.3
Assignee: mag@xamarin.com
URL:
Depends on:
Blocks:
 
Reported: 2016-03-11 16:52 UTC by James
Modified: 2017-07-19 07:37 UTC (History)
4 users (show)

Tags: papercut
Is this bug a regression?: ---
Last known good build:


Attachments
Sample connection error (11.40 KB, image/png)
2016-03-11 16:52 UTC, James
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description James 2016-03-11 16:52:33 UTC
Created attachment 15378 [details]
Sample connection error

Currently, when customers try to set up the Mac connection via Visual Studio, they get a somewhat cryptic error when the connection fails if the Xamarin tools are not installed on the Mac. All it states is

"Couldn't connect to [ip address]. Please try again"

The output also gives nothing but a "Permission denied"

This leads to confusion as customers will do an ssh or some other login to confirm they are able to connect. If possible, we should update our messaging to better check if the tooling is installed and inform the user otherwise.
Comment 1 Mikayla Hutchinson [MSFT] 2016-03-21 21:42:44 UTC
This seems like a pretty big bang for the buck in terms of improving UX.
Comment 3 xamarin-release-manager 2017-03-21 17:08:57 UTC
Fixed in version 99.1.0.848 (master)

Author: Mauro Agnoletti
Commit: 9aa3b30c6837b3845752a168fe577e8dfa532c53 (xamarin/XamarinVS)
Comment 4 Neeraj Deshmukh 2017-07-19 07:37:21 UTC
Verified on Visual Studio Enterprise 2017 for Mac (Preview)
Gist: https://gist.github.com/gangrade-swati/a142b17e8185ffe60367844369b72b12