Bug 3943 - Mandroid fails with non-english paths
Summary: Mandroid fails with non-english paths
Status: RESOLVED UPSTREAM
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 4.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2012-03-16 17:25 UTC by Jonathan Pobst
Modified: 2012-11-21 10:34 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED UPSTREAM

Description Jonathan Pobst 2012-03-16 17:25:51 UTC
If you create a project in a path with non-English characters, like: "c:\src\teståäö", mandroid fails with:

C:\Program Files (x86)\MSBuild\Novell\Novell.MonoDroid.Common.targets(790,3): error MSB6006: "mandroid.exe" exited with code -1. [C:\test\test†„”\AndroidApplication1\AndroidApplication1.csproj]

Tested on VS.
Comment 3 Atsushi Eno 2012-04-23 04:28:14 UTC
Just curious, is it MfA specific issue, or could it be mono general issue that fails to execute any external program in such paths?
Comment 5 dean.ellis 2012-11-21 10:34:01 UTC
We did some testing and had similar issues when trying to create normal Java projects using the Android tools. After some searching we found the following issues which exhibit similar problems.

http://code.google.com/p/android/issues/detail?id=4027
http://code.google.com/p/android/issues/detail?id=19084
http://code.google.com/p/android/issues/detail?id=834
http://code.google.com/p/android/issues/detail?id=38342

This seems to be a common problem with the android tool set, the accepted "workaround" is to not use non-English characters.