Bug 39398 - [UWP] Entry loses text alignment and keyboard type when IsPassword=true
Summary: [UWP] Entry loses text alignment and keyboard type when IsPassword=true
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.0.1
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-03-06 21:12 UTC by Adam
Modified: 2016-03-10 02:12 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Adam 2016-03-06 21:12:44 UTC
Version 2.1.0

I have a simple Entry control
<Entry HorizontalOptions="FillAndExpand" VerticalOptions="End" HeightRequest="50" HorizontalTextAlignment="Center" Keyboard="Numeric" />

This works well until you add  IsPassword="True"

Then the horizontal alignment gets ignored and the keyboard shows the default instead of numeric.
Comment 1 Paul DiPietro [MSFT] 2016-03-10 00:31:36 UTC
Which version of 2.1 are you using? I imagine you might be deploying to a Windows 10 phone/sim? Using that exact XAML on a page by itself seems to be fine for displaying the numeric keyboard even when IsPassword="True" is added. I appreciate any extra info on this one.
Comment 2 Adam 2016-03-10 02:10:52 UTC
Apologies, I was on 2.0.1. Just tested it in 2.1.0 and it looks like it has been resolved.
Comment 3 Paul DiPietro [MSFT] 2016-03-10 02:12:05 UTC
No problem! Thanks for the update.