Bug 39377 - ListView.Footer not update iOS
Summary: ListView.Footer not update iOS
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS ()
Version: 2.0.1
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-03-04 20:23 UTC by Raphael
Modified: 2016-04-07 12:46 UTC (History)
4 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Test Case (76.71 KB, application/x-zip-compressed)
2016-03-04 20:23 UTC, Raphael
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Raphael 2016-03-04 20:23:12 UTC
Created attachment 15271 [details]
Test Case

When setting a custom footer in iOS, after updating it, it do not appears anymore.

A topic in Xamarin Forms was opened: https://forums.xamarin.com/discussion/58822/system-invalidcastexception-object-must-implement-iconvertible-xamarin-footer-ios#latest

And a test project is attached.

After changing the FooterTemplate or even just the footer it do not works as expected.
Comment 1 Jason Smith [MSFT] 2016-03-14 06:41:03 UTC
Do you think you could attempt to dramatically simplify this test case? I have fixed the issue however I would like to turn this into a regression test to ensure we never screw this up in the future.

That said the current test is way too complex.
Comment 2 Jason Smith [MSFT] 2016-03-16 09:44:58 UTC
Should be fixed in 2.2.0-pre1
Comment 3 Parmendra Kumar 2016-04-07 12:46:20 UTC
I have checked this issue with Xamarin.Forms 2.2.0-pre1 and its working fine.

Hence closing this issue.