Bug 39174 - Editor control does not refresh text when BindingContext is changed in Windows/RT/UWP projects.
Summary: Editor control does not refresh text when BindingContext is changed in Window...
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-02-26 21:08 UTC by Mark Smith
Modified: 2017-03-20 19:10 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sample which shows Editor problem. (283.39 KB, application/zip)
2016-02-26 21:09 UTC, Mark Smith
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Mark Smith 2016-02-26 21:08:22 UTC
# Steps to reproduce
Run the attached program. This displays a label and Editor control both bound to the same object through the Page.BindingContext. It also has a set of buttons which change that binding context.

# Expected behavior
The label and editor view should stay synchronized.

# Actual behavior
On Windows (all variations), the Editor does not change it's text value.
Comment 1 Mark Smith 2016-02-26 21:09:09 UTC
Created attachment 15187 [details]
Sample which shows Editor problem.
Comment 2 John Hardman 2016-05-23 15:08:50 UTC
This is probably the same problem I am hitting on WinRT and UWP.

I have a single boolean property.
I have one image, for which IsVisible is bound to that boolean property.
I have a second image, for which IsVisible is bound using a converter to that boolean property. That converter simply does a Not on the value, so reverses true & false.

As a result, I would expect to see one image at any time. If I change the boolean, I would still expect to see one image, but now the other one.

On Android and iOS, this is what happens. On WinRT and UWP, only one of the bindings appears to be used, so I get an image or nothing, rather than one of two images.
Comment 3 John Hardman 2016-05-23 15:10:10 UTC
Just continuing my previous comment - if this is a case of only one binding being used per property, this is really fundamental and needs to be given high severity and priority IMHO.
Comment 4 John Hardman 2016-05-23 15:11:11 UTC
If you think it's a different issue, let me know and I will raise a separate bug as a matter of urgency.
Comment 5 John Hardman 2016-05-23 17:57:56 UTC
Actually, after further investigation, I'm going to raise what I am seeing as a new bug
Comment 6 Paul DiPietro [MSFT] 2017-03-20 19:10:35 UTC
This looks to be functioning correctly as of 2.3.4-pre5.