Bug 39160 - IndexOutOfRageException during android build
Summary: IndexOutOfRageException during android build
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 4.0.0 (C6)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-02-26 14:43 UTC by bartdk
Modified: 2016-12-23 00:21 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
IndexOutOfRangeException (96.32 KB, image/png)
2016-02-26 14:43 UTC, bartdk
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description bartdk 2016-02-26 14:43:51 UTC
Created attachment 15183 [details]
IndexOutOfRangeException

See screenshot for the exception we (randomly) get when building android solutions.
Comment 1 Daniel Cazzulino 2016-05-16 20:04:26 UTC
Does that happen while building or while debugging? (since the stacktrace shown seems to be about a debugger feature...).

As soon as this happens, could you please go to Help | Xamarin | Zip Logs and attach the resulting .zip file to this bug? This would help us identify the issue.

Also, if you could also paste the version information from Help | About Microsoft Visual Studio, that would be helpful too.
Comment 2 Jose Gallardo 2016-12-23 00:21:38 UTC
Hi,
We've added several improvements to our build system and deploying/debugging mechanism since the bug was reported, and as we couldn't reproduce it on our end I'm resolving it tentatively as Not_Reproducible.
That said, if you're still facing this issue with current bits, please feel free to reopen the bug and provide the requested information.
Thanks