Bug 39142 - Release mode with AOT compilation results in a bunch of cmd windows stealing focus
Summary: Release mode with AOT compilation results in a bunch of cmd windows stealing ...
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler ()
Version: 6.0.1 (C6SR1)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: João Matos
URL:
Depends on:
Blocks:
 
Reported: 2016-02-26 00:38 UTC by Robert
Modified: 2016-07-19 11:26 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Robert 2016-02-26 00:38:20 UTC
I'm on Windows 10 x64. Compiling in release mode with AOT results in a lot of cmd windows that steal focus, making the machine unusable during this time.

http://screencast.com/t/WyaExOgdjb
Comment 1 Jonathan Pryor 2016-03-02 03:03:41 UTC
@Joao: Presumably we just need to ensure that the compilers are compiled as GUI apps and not CONSOLE apps?
Comment 2 João Matos 2016-03-03 17:16:45 UTC
Right, that change should be enough.
Comment 3 João Matos 2016-03-16 14:49:07 UTC
I have been trying to repro this over here and haven't been able so far (Windows 8).

Robert, do you know if this is Windows 10 specific?
Comment 4 João Matos 2016-07-13 11:07:05 UTC
I have been trying to reproduce this with the same environment you reported (Windows 10 x64, with VS 2015 and latest Xamarin.Android) but do not see these windows popping up.

Do you mind checking with the latest release and see if it's still a problem on your machine?
Comment 5 João Matos 2016-07-19 11:26:05 UTC
Please re-open if you can reproduce this issue in the future.