Bug 3914 - BuildEventContext is not found under Microsoft.Build.Framework 4.0 assembly
Summary: BuildEventContext is not found under Microsoft.Build.Framework 4.0 assembly
Status: NEW
Alias: None
Product: Tools
Classification: Mono
Component: xbuild ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-03-15 11:13 UTC by Eugene Petrenko
Modified: 2012-03-15 12:58 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 3914 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description Eugene Petrenko 2012-03-15 11:13:47 UTC
I have MSBuild logger compiled for MSBuild 4.0.
My logger deals with BuildEventContext to get information about nodes. 

As it turned out, xbuild v4.0 assemblies does not have such API, while having assemblies of version 4.0. This make my listener to fail with:

Could not load type 'Microsoft.Build.Framework.BuildEventContext' from assembly 'Microsoft.Build.Framework, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'.
System.TypeLoadException: Could not load type 'Microsoft.Build.Framework.BuildEventContext' from assembly 'Microsoft.Build.Framework, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'.
  at JetBrains.BuildServer.MSBuildLoggers.Logging.Multicaster.GetLoggingKey (Microsoft.Build.Framework.BuildEventArgs args) [0x00000] in <filename unknown>:0 
  at JetBrains.BuildServer.MSBuildLoggers.Logging.Multicaster.FindProcessor[MSBuildMessageLogger] (Microsoft.Build.Framework.BuildEventArgs args) [0x00000] in <filename unknown>:0 
  at JetBrains.BuildServer.MSBuildLoggers.MSBuildLoggerImpl+<>c__DisplayClass7.<OnMessageRaised>b__6 () [0x00000] in <filename unknown>:0 
  at JetBrains.BuildServer.MSBuildLoggers.MSBuildLoggerImpl.Catch (Microsoft.Build.Framework.BuildEventArgs evt, 
JetBrains.BuildServer.MSBuildLoggers.Action a) [0x00000] in <filename unknown>:0 


Please drop non-compatible API dlls or fill the gap in APIs.


Related issue: http://youtrack.jetbrains.com/issue/TW-20696
Comment 2 Mikayla Hutchinson [MSFT] 2012-03-15 12:58:57 UTC
We have not implemented 3.5 and 4.0 MSBuild hosting APIs - MonoDevelop doesn't need them. They should probably be stubbed though.