Bug 3912 - Incorect behavior of System.Reflection.Emit.ParameterBuilder.SetConstant()
Summary: Incorect behavior of System.Reflection.Emit.ParameterBuilder.SetConstant()
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: mscorlib ()
Version: master
Hardware: PC Linux
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-03-15 10:40 UTC by Gleb Golubitsky
Modified: 2012-03-15 12:25 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
test code (1.09 KB, text/x-csharp)
2012-03-15 10:40 UTC, Gleb Golubitsky
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Gleb Golubitsky 2012-03-15 10:40:15 UTC
Created attachment 1520 [details]
test code

System.Reflection.Emit.ParameterBuilder.SetConstant(System.Object defaultValue) behaves wrong compared to MS CLR. The problem is in wrong handling cases when Type of parameter described by ParameterBuilder is defined by System.Reflection.Emit.TypeBuilder object (not System.Type).

Maybe my explaination sounds is a bit confusing, so the problem is illustrated in the attached example code.

Affected version: master

Expected output:
PASS

Got output:
FAIL
Exception: System.ArgumentException: Constant does not match the defined type.
  at System.Reflection.Emit.ParameterBuilder.SetConstant (System.Object defaultValue) [0x00000] in <filename unknown>:0 
  at SystemReflectionEmitParameterBuilderSetConstantTest.Main () [0x00000] in <filename unknown>:0 

Pull request with a patch & test case will follow soon at github.
Comment 1 Gleb Golubitsky 2012-03-15 11:16:15 UTC
Pull request with patch and test case filed.

https://github.com/mono/mono/pull/245
Comment 2 Rodrigo Kumpera 2012-03-15 12:25:26 UTC
Pulled! Thanks for the patch.