Bug 39089 - Microsoft.Owin Unhandled Loader Error
Summary: Microsoft.Owin Unhandled Loader Error
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Runtime
Classification: Mono
Component: packaging ()
Version: 4.2.0 (C6)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Alexis Christoforides
URL:
Depends on:
Blocks:
 
Reported: 2016-02-24 11:11 UTC by Rui Queiros
Modified: 2017-05-16 22:06 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Rui Queiros 2016-02-24 11:11:32 UTC
0
down vote
favorite
I am trying to run a .NET Dockerfile on Docker.

My dockerfile has the following stuff:

FROM mono:4.2.2.30
COPY MicroDK.dll ./
COPY MSHost.exe ./
COPY MSPlat.dll ./
CMD [ "mono",  "./MSHost.exe" ]

I can build the image, but when I try to run I have a bunch of errors regarding Microsoft.Owin:

This is the error:

Unhandled loader error: 8, (null) Microsoft.Owin, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35 (null)
* Assertion: should not be reached at loader.c:298

After a while I got Stack Overflow:

Stack overflow: IP: 0x7fad9b4ff2fc, fault addr: (nil)
Stacktrace:

I also find out that before the unhandled load error starts spamming it says: "Got a SIGABRT while executing native code. This usually indicates a fatal error in the mono runtime or one of the native libraries used by our application."

Any tips? Or ideia what might be and how to avoid it?
Comment 1 Alexander Köplinger [MSFT] 2017-05-16 22:06:02 UTC
Hey, sorry for the late answer, this was filed in a component that wasn't monitored for runtime bugs. I hope the issue was fixed in the meantime, if it still occurs please open a bug in the Runtime component.
Comment 2 Alexander Köplinger [MSFT] 2017-05-16 22:06:38 UTC
Correction: I meant Runtime *product*, not component.