Bug 39039 - Toggling Grouping on Listview + ListViewCaching.RecycleElement Sometimes Doesnt Render Group Header
Summary: Toggling Grouping on Listview + ListViewCaching.RecycleElement Sometimes Does...
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.0.0
Hardware: PC Windows
: Normal major
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-02-23 12:02 UTC by FieldstrikeMobile
Modified: 2016-04-25 16:37 UTC (History)
5 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Repo Case (593.15 KB, application/zip)
2016-02-23 12:02 UTC, FieldstrikeMobile
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description FieldstrikeMobile 2016-02-23 12:02:03 UTC
Created attachment 15148 [details]
Repo Case

So I have adapted a James Montemagno Monkeys sample to allow you to Toggle whether the list is grouped using the Toggle Grouping in the top left.

Load the application (Everything is grouped Correctly)
Scroll down a bit
Click the "toggle Group" button to turn off grouping
Now click the "Toggle Group" button again to turn on grouping
Now some GroupHeaders do not contain their template. i.e. where the alphabet characters should be they are now blank

You may have to reload the application a couple of times if it doesnt work the first time, the bug seems to be sporadic.

Note: Setting ListViewCaching.RetainElement gets rid of this error

(only tested on Android)
Comment 1 FieldstrikeMobile 2016-02-23 12:02:57 UTC
This could be an extension of this bug: https://bugzilla.xamarin.com/show_bug.cgi?id=37270

But as the user didn't include much details about his bug I couldn't tell so have made a new one in case this is different
Comment 2 Jason Smith [MSFT] 2016-03-14 07:18:01 UTC
The issue seems to be that the bucketing of the which view goes with which data type seems to be getting lost when grouping is toggled in recycleview. Looking into it.
Comment 3 Jason Smith [MSFT] 2016-03-16 11:03:01 UTC
Should be fixed in 2.2.0-pre1
Comment 4 Parmendra Kumar 2016-04-25 16:37:45 UTC
I have checked this issue with Xamarin.Forms 2.2.0-pre4 and its working fine.

Hence closing this issue.