Bug 38827 - UWP - Text not wrapping
Summary: UWP - Text not wrapping
Status: CONFIRMED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.1
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-02-17 01:13 UTC by James Montemagno [MSFT]
Modified: 2016-07-29 07:44 UTC (History)
6 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
repro solution (276.01 KB, application/x-zip-compressed)
2016-07-06 00:29 UTC, Jimmy [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 38827 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description James Montemagno [MSFT] 2016-02-17 01:13:54 UTC
When you are using a grid and a stack panel the text does not wrap and gets cut off. Works fine on iOS/Android. Built and tested against 2.1.0-pre4

You can use this to repo:

<?xml version="1.0" encoding="UTF-8"?>
<ContentPage xmlns="http://xamarin.com/schemas/2014/forms"
             xmlns:x="http://schemas.microsoft.com/winfx/2009/xaml"
             x:Class="Xamarin.Forms.Controls.Bugzilla27318">
    <ScrollView>
        <Grid RowSpacing="5" 
              ColumnSpacing="5">
           <Grid.RowDefinitions>
            <RowDefinition Height="Auto"/>
            <RowDefinition Height="*"/>
            <RowDefinition Height="Auto"/>
           </Grid.RowDefinitions>

           <StackLayout>
                    <Label HorizontalTextAlignment="Center"
                           HorizontalOptions="FillAndExpand"
                           StyleId="LoginPageIdentifier"
                           FontSize="Large"
                           Text="Sign in with your Xamarin account to save and sync favorites and session feedback."/>
               
            </StackLayout>
        </Grid>
   </ScrollView>
</ContentPage>
Comment 2 Jimmy [MSFT] 2016-07-06 00:29:39 UTC
Created attachment 16581 [details]
repro solution

I'm still able to reproduce this issue with Forms 2.3.1.111-pre2 on desktop and mobile. I've attached a repro solution.

### Steps to Reproduce
1. Run the UWP project 
2. If on the desktop, resize the window's width to its minimum
Comment 3 FieldstrikeMobile 2016-07-29 07:44:06 UTC
This bug is a duplicate of :https://bugzilla.xamarin.com/show_bug.cgi?id=42559