Bug 38778 - listview in landscape only on iOS iPAD
Summary: listview in landscape only on iOS iPAD
Status: RESOLVED ANSWERED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.0.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-02-15 23:48 UTC by Alessandro
Modified: 2016-02-16 06:49 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Alessandro 2016-02-15 23:48:35 UTC
Hi.
I have a MasterDetail. 
In the Detail I have a simple ListView.
This ListView works fine on iPhone

https://www.dropbox.com/s/pptcslnlknuifu8/Screenshot%202016-02-16%2000.41.16.png?dl=0
https://www.dropbox.com/s/dogy7vd5hc5xpdt/Screenshot%202016-02-16%2000.41.30.png?dl=0

but if I use the same ListView on a iPad (I am working on a simulator but a friend of mine tell me that also on a real device there is this problem) I have this

https://www.dropbox.com/s/074nffy1m1n2t2q/Screenshot%202016-02-16%2000.43.47.png?dl=0

how you can see, the dividing line is not long as the list

It's a bug?

Thanks
Alessandro
Comment 1 Paul DiPietro [MSFT] 2016-02-16 00:12:00 UTC
This is due to changes in iOS9. You can see similar discussion of the issue and ways to resolve it here: http://forums.xamarin.com/discussion/50915/listview-on-ios-9-not-filling-screen-width-issue-with-custom-viewcell
Comment 2 Alessandro 2016-02-16 06:49:37 UTC
Thanks Paul, so I can consider it as not a bug?