Bug 38760 - Wrong catching exceptions when using the LLVM compiler
Summary: Wrong catching exceptions when using the LLVM compiler
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Mono runtime / AOT compiler ()
Version: XI 9.4 (iOS 9.2)
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: (C7)
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2016-02-15 12:54 UTC by YuraS
Modified: 2016-05-19 18:45 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
sample project (3.70 KB, application/zip)
2016-02-15 12:54 UTC, YuraS
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description YuraS 2016-02-15 12:54:09 UTC
Created attachment 15044 [details]
sample project

The sample app demonstrates catching wrong type exceptions. Works fine when don't use LLVM.

=== Xamarin Studio ===

Version 5.10.2 (build 56)
Installation UUID: ece0225a-0666-4b5a-8533-b9b18e928081
Runtime:
	Mono 4.2.2 (explicit/996df3c)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402020030

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 7.2.1 (9548.1)
Build 7C1002

=== Xamarin.iOS ===

Version: 9.4.1.25 (Business Edition)
Hash: 962a050
Branch: master
Build date: 2016-01-29 16:59:11-0500


=== Xamarin.Mac ===

Version: 2.4.1.6 (Starter Edition)

=== Build Information ===

Release ID: 510020056
Git revision: bb74ff467c62ded42b7b7ac7fdd2edc60f8647b0
Build date: 2016-01-26 16:24:41-05
Xamarin addins: 8b797d7ba24d5abab226c2cf9fda77f666263f1b
Build lane: monodevelop-lion-cycle6-c6sr1

=== Operating System ===

Mac OS X 10.11.3
Darwin samkevichy.local 15.3.0 Darwin Kernel Version 15.3.0
    Thu Dec 10 18:40:58 PST 2015
    root:xnu-3248.30.4~1/RELEASE_X86_64 x86_64
Comment 1 Sebastien Pouliot 2016-02-15 22:16:23 UTC
This works fine for armv7 and arm64 using master, both with and without LLVM.

This is likely already fixed but I'll let Zoltan see if it's a known duplicate of some other bugs before it's close.
Comment 2 Zoltan Varga 2016-02-15 23:41:39 UTC
Its likely a dup of:
https://bugzilla.xamarin.com/show_bug.cgi?id=37273
Which is targeted at cycle6sr2.
Comment 3 Sebastien Pouliot 2016-02-16 19:39:43 UTC
Thanks for the dupe candidate.
Closing the bug as QA can verify the fix is already in master