Bug 38741 - Error retrieving Info.plist project item
Summary: Error retrieving Info.plist project item
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.0.0 (C6)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-02-13 21:44 UTC by Tom Gilder
Modified: 2016-04-22 15:08 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Logs (403.82 KB, application/zip)
2016-02-13 21:44 UTC, Tom Gilder
Details
Exception stacktrace (2.52 KB, text/plain)
2016-02-14 10:52 UTC, Tom Gilder
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Tom Gilder 2016-02-13 21:44:27 UTC
Created attachment 15036 [details]
Logs

Visual Studio is being very slow and I suspect Xamarin is the cause, as it's logging "Error retrieving Info.plist project item" 15 times every second.

Logs attached.
Comment 1 Tom Gilder 2016-02-13 21:51:26 UTC
Ah, turns out I did have a UI test iOS project without an Info.plist.

Probably shouldn't be freezing VS though :)
Comment 2 Tom Gilder 2016-02-14 10:38:45 UTC
Update: I removed the project that was missing Info.plist, but I'm still getting the slowdown and logs.

The only remaining iOS project does have an Info.plist.
Comment 3 Tom Gilder 2016-02-14 10:52:50 UTC
Created attachment 15037 [details]
Exception stacktrace

I attached a debugger to devenv.exe, and Xamarin is throwing hundreds of NotImplementedExceptions, stacktrace attached.
Comment 4 Enzo Heredia 2016-04-07 14:15:59 UTC
Hi Tom,
I'm not able to reproduce the problem you are describing, I just attached a debugger to devenv.exe and not seeing exceptions.

Can you please provide some more information:

- When you get the exceptions, which operation are you doing on VS?

Also please provide Xamarin build information.

Thanks!
Comment 5 Daniel Cazzulino 2016-04-22 15:08:31 UTC
Thanks Tom for reporting this!

After carefully looking at the logs and stacktrace you attached, 
we could verify that a refactoring we did on that code path 
should fix the issue in an upcoming release. 

We also improved the code that was previously throwing unnecessary 
exceptions from calls to VS DTE with a non-throwing alternative, 
which should also speed things up.