Bug 3868 - Could not set X locale modifiers
Summary: Could not set X locale modifiers
Status: NEW
Alias: None
Product: Class Libraries
Classification: Mono
Component: Windows.Forms ()
Version: 2.10.x
Hardware: PC Linux
: Lowest normal
Target Milestone: Community
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-03-13 04:53 UTC by dglassey
Modified: 2017-09-01 11:56 UTC (History)
3 users (show)

Tags: mono-community
Is this bug a regression?: ---
Last known good build:


Attachments
XSetLocaleModifiers returns a char* not a bool (1.38 KB, patch)
2012-03-13 04:53 UTC, dglassey
Details
change dispose to destructor (1.15 KB, patch)
2012-03-13 04:54 UTC, dglassey
Details
retry SetupXIM (2.16 KB, patch)
2012-03-13 04:55 UTC, dglassey
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 3868 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description dglassey 2012-03-13 04:53:34 UTC
Created attachment 1504 [details]
XSetLocaleModifiers returns a char* not a bool

Sometimes when a form with a text control is created this message appears on the console. Once this happens it is not possible to type into the control with an input method e.g. ibus.

See Novell bug 436000 https://bugzilla.novell.com/show_bug.cgi?id=436000 for a simple test program that shows the problem when run repeatedly - it isn't consistent enough for a proper test case. And more issues that may come from the same problem.

Looking at the man page for XSetLocaleModifiers it returns a char *. But the mono code in System.Windows.Forms/X11Keyboard.cs has it returning a bool.

patch 1 changes it to return an IntPtr

Another issue raised in 436000 is that the X11Keyboard Dispose is never called.
patch 2 changes it to a destructor since it clears up unmanaged X things.

patch 3 is less important and retries SetupXIM later if it fails because of XSetLocaleModifiers
Comment 1 dglassey 2012-03-13 04:54:56 UTC
Created attachment 1505 [details]
change dispose to destructor
Comment 2 dglassey 2012-03-13 04:55:28 UTC
Created attachment 1506 [details]
retry SetupXIM