Bug 3864 - "Run again" menu entry is confusing when debugging, should be "Debug again"
Summary: "Run again" menu entry is confusing when debugging, should be "Debug again"
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: 2.8.6
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2012-03-12 16:31 UTC by Rogier van der Hee
Modified: 2012-03-14 15:14 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Rogier van der Hee 2012-03-12 16:31:35 UTC
I almost always choose Debug as Run option and the menu option "Run again" does NOT do Debug again but switches to Run mode.

When I pressed Debug and am in Debugging session, to me it seems more logical that this menu entry reads "Debug again", so that I can easily restart my session in Debug mode. Now I have to click stop and Debug again..
Comment 1 Jeffrey Stedfast 2012-03-14 15:14:07 UTC
Fixed in git master.