Bug 3851 - Unexpected error - Creating app in distribution mode
Summary: Unexpected error - Creating app in distribution mode
Status: RESOLVED DUPLICATE of bug 3559
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 5.2
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-03-12 04:08 UTC by peter.schade
Modified: 2012-03-13 04:21 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 3559

Description peter.schade 2012-03-12 04:08:12 UTC
Hello,

since I updated MonoTouch to the version 5.2.5 (MonoDevelope 2.8.6.5) i can not create my apps for distribution. I tried to use an ad-hoc and in-house profile but nothing works. 

The error i got:

Error MT0000: Unexpected error - Please fill a bug report at http://bugzilla.xamarin.com (MT0000)


/usr/bin/strip -s "/var/folders/sb/3z2x5mqj0bjgpfqnbpj87jdm0000gn/T/tmp581e1083.tmp/symbol-file" "/Users/UserXY/Desktop/Projects/MyApp/bin/iPhone/Distribution/MyApp.app/MyApp"
error MT0000: Unexpected error - Please fill a bug report at http://bugzilla.xamarin.com
System.ComponentModel.Win32Exception: ApplicationName='/usr/bin/strip', CommandLine='-s "/var/folders/sb/3z2x5mqj0bjgpfqnbpj87jdm0000gn/T/tmp581e1083.tmp/symbol-file" "/Users/userXY/Desktop/Projects/MyApp/bin/iPhone/Distribution/MyApp.app/myApp"', CurrentDirectory=''
  at System.Diagnostics.Process.Start_noshell (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) [0x00000] in <filename unknown>:0 
  at System.Diagnostics.Process.Start_common (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) [0x00000] in <filename unknown>:0 
  at System.Diagnostics.Process.Start (System.Diagnostics.ProcessStartInfo startInfo) [0x00000] in <filename unknown>:0 
  at MTouch.RunCommand (System.String path, System.String args, System.String[] env) [0x00000] in <filename unknown>:0 
  at MTouch.RunCommand (System.String path, System.String args) [0x00000] in <filename unknown>:0 
  at MTouch.Main2 (System.String[] args) [0x00000] in <filename unknown>:0 
  at MTouch.Main (System.String[] args) [0x00000] in <filename unknown>:0 


Thanks for your help!
Comment 1 Rolf Bjarne Kvinge [MSFT] 2012-03-12 06:09:48 UTC
You need to install the optional command line tools in Xcode (Preferences -> Downloads), they're not included by default anymore.

See comment #3 of bug #3559 for more information

*** This bug has been marked as a duplicate of bug 3559 ***
Comment 2 peter.schade 2012-03-13 04:21:26 UTC
It works with the command line tools. Thank you!