Bug 38415 - Layouts moved to subfolder of layout, can not be opened using visual designer
Summary: Layouts moved to subfolder of layout, can not be opened using visual designer
Status: RESOLVED ANSWERED
Alias: None
Product: Android
Classification: Xamarin
Component: Designer ()
Version: 6.0.1 (C6SR1)
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Jérémie Laval
URL:
Depends on:
Blocks:
 
Reported: 2016-02-03 23:25 UTC by dj_technohead
Modified: 2017-06-27 05:45 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description dj_technohead 2016-02-03 23:25:52 UTC
After moving layouts to a subfolder, double clicking on them in Xamarin Studio brings up the code editor, rather than the visual design editor. Moving them back to the layouts folder, and then this works again.
Comment 1 Prashant [MSFT] 2017-06-27 05:45:12 UTC
This works as expected, Xamarin Studio recognises the layout files source files when moved to the subfolders.

This behaviour is consistent with Android Studio