Bug 38307 - Windows Phone 8.1 Labels width not expanding
Summary: Windows Phone 8.1 Labels width not expanding
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows ()
Version: 2.0.0
Hardware: PC Mac OS
: Normal blocker
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-02-02 15:39 UTC by John Miller [MSFT]
Modified: 2016-02-17 11:41 UTC (History)
5 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Sample Project (68.28 KB, application/zip)
2016-02-02 15:39 UTC, John Miller [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description John Miller [MSFT] 2016-02-02 15:39:39 UTC
Created attachment 14850 [details]
Sample Project

**Overview:**

   After updating to 2.1, Labels in a ViewCell are truncating after the first letter. 

**Steps to Reproduce:**

   1. Run the attached sample with 2.1 on Windows Phone 8.1 device

**Actual Results:**

   Notice that only 1 character displays in the cells O and T

**Expected Results:**

   It should show "Online" and "Test". 

**Build Date & Platform:**

   XF 2.1pre3

**Additional Information:**

   Downgrade to XF 2.0 to see expected results.
Comment 1 Anonymous 2016-02-02 17:52:42 UTC
I was just about to report this. I've also noticed this when using the new DataTemplateSelector. This pretty much makes Windows RT unusable right now for us. Can I request a bump in priority when this gets reviewed?
Comment 2 Jason Smith [MSFT] 2016-02-09 02:53:36 UTC
Should be fixed in 2.1.0-pre4
Comment 3 Parmendra Kumar 2016-02-17 11:41:29 UTC
I have checked this issue with Xamarin.Forms 2.1.0-pre4 and now its working fine. Screencast: http://www.screencast.com/t/2Qqfuka4BZ

Hence closing this issue.

Thanks.