Bug 38288 - New (empty) iOS project crashes on launch with no error on iPad
Summary: New (empty) iOS project crashes on launch with no error on iPad
Status: RESOLVED NORESPONSE
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: XI 9.4 (iOS 9.2)
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-02-02 00:21 UTC by bobme981
Modified: 2016-04-12 17:40 UTC (History)
7 users (show)

Tags: BZSRC6SR1S2
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description bobme981 2016-02-02 00:21:19 UTC
We applied patch version 9.4.1.25, and our iOS app no longer runs. We can't even get a completely new (empty) iOS app to run.

REPRO
=================================
1. Create a new cross-platform iOS app in Xamarin Studio
2. Run empty app on iPad 4/iOS 9.2

RESULT:
Near-immediate app exit with no error. 
There is nothing in Application Output window or iOS device log, and no log file present in XM Studio 5.0 folder.
Will hit a breakpoint in AppDelegate.FinishedLaunching, but will still crash within 15 seconds while paused in the debugger (it appears the device OS is killing the app).
App will crash with and without debugger attached.

Repros on two different iPad 4 devices
Works fine on simulator for iPad 2/iOS 9.2
Comment 1 bobme981 2016-02-02 00:48:59 UTC
Uninstalling all Xamarin apps from the device and rebooting it does not resolve the issue.
Comment 3 Sebastien Pouliot 2016-02-02 00:59:00 UTC
This sounds like two different issues:

1. The iOS watchdog kills applications that do not respond while executing the FinishedLaunching method (you have about 20 seconds from when iOS starts your process).

This only happens on device (not on the simulator) but this behaviour exists across all versions of Xamarin.iOS;


2. If your application crash then it should print something in the device logs (look using Xcode's device window).

It's possible that you won't see a crash report if iOS has reached it's limit (but the device logs will show you a warning). Sync'ing your device with iTunes will move the crash reports locally and allow the device to record new ones.

Please attach the device logs information on the bug report.
Comment 5 Shruti 2016-02-02 08:57:58 UTC
I have tried to reproduce this issue using Xamarin.Forms Portable and Shared Project on iPAD 4 iOS 9.2.1, iPAD 3 iOS 9.2.1, iPAD Mini iOS 9.3, iPAD 2 iOS 9.2 But not able to reproduce it.

I am able to deploy both applications successfully on device as well using breakpoint. We having only iOS 9.2 with iOS 9.2, others are either of old version or updated with new version.

Screencast: http://www.screencast.com/t/yGNlk1Qbzqi

Environment Info: https://gist.github.com/shrutis360/db29b56efa63a973ffe1
Comment 6 GouriKumari 2016-02-17 18:13:20 UTC
Moving the target milestone to C7.
Comment 7 Brendan Zagaeski (Xamarin Team, assistant) 2016-02-19 19:06:38 UTC
@bobme981, to follow-up on this briefly once more, if you're still seeing this issue, then whenever you get a chance to try clearing out the crash reports (as mentioned in item "2." on Comment 3), collect the new crash report and device logs [1], and attach those back, that will be perfect.

Thanks in advance!


[1] "iOS device logs" on https://kb.xamarin.com/customer/portal/articles/1675684-where-can-i-find-my-version-information-and-logs-
Comment 9 Sebastien Pouliot 2016-04-12 17:40:16 UTC
We have not received further information and will assume this is not an issue anymore. If you can still affected by this please re-open the bug and include the requested information. Thanks.