Bug 38260 - Windows Phone 8.1 ListView is slow when navigating back since 2.1
Summary: Windows Phone 8.1 ListView is slow when navigating back since 2.1
Status: RESOLVED NOT_ON_ROADMAP
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows ()
Version: 2.0.0
Hardware: PC Mac OS
: Normal blocker
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-02-01 17:13 UTC by John Miller [MSFT]
Modified: 2017-06-20 19:53 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sample Project (68.28 KB, application/zip)
2016-02-01 17:13 UTC, John Miller [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_ON_ROADMAP

Description John Miller [MSFT] 2016-02-01 17:13:01 UTC
Created attachment 14836 [details]
Sample Project

**Overview:**

   After updating to 2.1 (pre2/pre3), ListView navigation on Windows Phone is impressively slow. 2.0 seems to be OK. 

**Steps to Reproduce:**

   1. Run the attached on a Windows Phone 8.1 device
   2. Tap on a cell to navigate.
   3. Tap back / back button

**Actual Results:**

   It takes a few seconds to go back.

**Expected Results:**

   It should not take this long to navigate back.

**Build Date & Platform:**

   XF 2.1pre3
Comment 1 John Miller [MSFT] 2016-02-10 15:37:34 UTC
Tested with 2.1pre4 on Nokia Lumia 521, and it is still slow. It takes 4-5 seconds for it to navigate back after pressing the back button.
Comment 2 Mike 2016-10-26 19:22:56 UTC
Did it same as this: https://bugzilla.xamarin.com/show_bug.cgi?id=41975
Comment 3 Mike 2016-12-08 07:59:06 UTC
Also please check these too:
https://bugzilla.xamarin.com/show_bug.cgi?id=46856
https://bugzilla.xamarin.com/show_bug.cgi?id=48682

Maybe that's not only about ListView, It's a page design problem.
Comment 4 David Ortinau [MSFT] 2017-06-20 19:52:46 UTC
As indicated on our public Roadmap, Windows Phone 8 and 8.1 targets are no longer in development and will no longer be supported with the release of 3.0 due out in Q3 of 2017.