Bug 3815 - Dock Panels Label color is hardcoded to Black
Summary: Dock Panels Label color is hardcoded to Black
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Docking ()
Version: unspecified
Hardware: PC All
: Lowest normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-03-08 12:53 UTC by D. Soronda
Modified: 2015-12-02 13:21 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
zip file with screenshots of mouse off and mouse over (108.00 KB, application/zip)
2012-03-08 12:53 UTC, D. Soronda
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description D. Soronda 2012-03-08 12:53:24 UTC
Created attachment 1486 [details]
zip file with screenshots of mouse off and mouse over

Monodevelop dock component text label is hardcoded to Black.
By using dark GTK themes, it is almost impossible to find proper dock panel until mouse over it.

Same error is on Windows and Linux versions of Monodevelop.

Solution: remove hardcoded color and let GTK theme to set color.
Comment 1 Abhishek 2015-12-02 13:21:50 UTC
Now behavior of Xamarin studio has been changed. I am unable to reproduce this issue with the latest C6 build. 

Environment info:

=== Xamarin Studio ===

Version 5.10.2 (build 14)
Installation UUID: 9964a087-9af9-4da0-aa20-07ca4b85f306
Runtime:
	Microsoft .NET 4.0.30319.42000
	GTK+ 2.24.23 (MS-Windows theme)
	GTK# 2.12.26

=== Xamarin.Profiler ===

Version: 0.16.56.0
Location: C:\Program Files (x86)\Xamarin\Profiler\XamarinProfiler.exe

=== Xamarin.Android ===

Version: 6.0.0.34 (Enterprise Edition)
Android SDK: D:\android-sdk
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
		5.1    (API level 22)
		6.0    (API level 23)

SDK Tools Version: 24.3.4

SDK Platform Tools Version: 23.0.1

SDK Build Tools Version: 23


Java SDK: C:\Program Files (x86)\Java\jdk1.7.0_71
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) Client VM (build 24.71-b01, mixed mode, sharing)

=== Xamarin Android Player ===

Version: 0.6.1
Location: C:\Program Files\Xamarin Android Player\DeviceManager.exe

=== Build Information ===

Release ID: 510020014
Git revision: a05150ff9af3205952d9f2ab4417f8036205c035
Build date: 2015-11-30 15:14:42-05
Xamarin addins: e89ff179a2cbe19b4eca4ac3859248e25c20225a
Build lane: monodevelop-windows-cycle6

=== Operating System ===

Windows 6.1.7601.65536 (64-bit)