Bug 38096 - NullReference exception when removing ContentView content
Summary: NullReference exception when removing ContentView content
Status: RESOLVED NORESPONSE
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.0.0
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Rui Marinho
URL:
Depends on:
Blocks:
 
Reported: 2016-01-27 14:43 UTC by John Miller [MSFT]
Modified: 2017-06-19 21:14 UTC (History)
6 users (show)

Tags: ContentView NullReference
Is this bug a regression?: ---
Last known good build:


Attachments
Stack Trace (1.74 KB, text/plain)
2016-01-27 14:43 UTC, John Miller [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description John Miller [MSFT] 2016-01-27 14:43:06 UTC
Created attachment 14755 [details]
Stack Trace

**Overview:**

   Occasionally modifying a ContentViews Content at runtime will throw a null reference exception. 

**Steps to Reproduce:**

   Unknown at this time. 

**Actual Results:**

   See attached for stack trace.

**Expected Results:**

   No exception.

**Build Date & Platform:**

   XF 2.0

**Additional Information:**

   Customer reports seeing this after updating from 1.2 -> 2.0.
Comment 1 Rui Marinho 2016-01-27 18:25:56 UTC
Thank you for taking the time to submit the bug. We tried to reproduce the issue you reported but were unable given the description. If you could please attach a reproduction to the bug by starting with a clean Xamarin.Forms project and adding just the code necessary to demonstrate the issue we would very much appreciate it.

Warm regards,
Xamarin Forms Team
Comment 2 Chris King 2017-06-19 17:21:11 UTC
Assigned to you as you were last to request additional info.
Comment 3 Samantha Houts [MSFT] 2017-06-19 21:14:26 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!