Bug 38092 - The view which has been added using Dispatcher in native UWP platform is not visible at load time in Xamarin.Forms UWP
Summary: The view which has been added using Dispatcher in native UWP platform is not ...
Status: CONFIRMED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows ()
Version: unspecified
Hardware: PC Windows
: High normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-01-27 11:33 UTC by Magesh Kumar
Modified: 2017-06-16 19:13 UTC (History)
3 users (show)

Tags: ac, renderer, uwp
Is this bug a regression?: ---
Last known good build:


Attachments
The view which has been added using Dispatcher in native UWP platform is not visible at load time in Xamarin.Forms UWP, and the view is visible after resize the application. (77.12 KB, application/zip)
2016-01-27 11:33 UTC, Magesh Kumar
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 38092 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Magesh Kumar 2016-01-27 11:33:14 UTC
Created attachment 14752 [details]
The view which has been added using Dispatcher in native UWP platform is not visible at load time in Xamarin.Forms UWP, and the view is visible after resize the application.

** Steps to Reproduce **

1. Run the attached sample in UWP. 
2. View will not visible initially.
3. Resize the window the view will be visible.
Comment 1 Rui Marinho 2016-01-27 20:16:08 UTC
Hi Magesh what is happening is you need to tell Forms to reevaluate the size of your item after it's added, i created a guest with a modified sample.

https://gist.github.com/rmarinho/79933e7981d5b80e9a47

Note  that you need to add: 

> ((IVisualElementController)this.element).NativeSizeChanged ();
Comment 2 Magesh Kumar 2016-01-28 06:46:41 UTC
Hi Rui,

Thanks for the update.

The above issue resolved with your solution. But whenever i resize the window (Resize left or Right) the view is not visible with the same sample which includes your solution also.
Comment 3 David Ortinau [MSFT] 2017-06-16 19:13:14 UTC
I have confirmed this odd behavior using 2.3.5.239-pre3. I'm not clear if this is Xamarin.Forms or UWP.  We'll take a closer look.