Bug 38085 - Assembly name bug in shared projects
Summary: Assembly name bug in shared projects
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-01-27 08:19 UTC by steve hawkins
Modified: 2016-12-21 17:51 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description steve hawkins 2016-01-27 08:19:25 UTC
The bug is that in an ios project if I change the assembly name and compile this works fine and created the assembly. But when I save the project and exit visual studio and reopen the project the ios assembly name reverts back to the original and not the changed name.

Steps to reproduce:

1) create a new shared xamarin forms project called: mytest.forms.com in visual studio (im using 2013 update 5 with XF4 installed but same issue with XF2)
2) delete the ios project and delete from disk
3) add a new blank xamarin ios project named : mytestformscom (this will add ok) and save.
4) goto into the ios project properties and change the assembly name to mytest.forms.com (with the dots) and compile and it will compile fine.
5) save everything and exit visual studio.
6) reopen project and goto ios properties and assembly name and it will have reverted back to the name with no dots in it.

Also tried changing in notepad++ etc and same issue. also delete sou file etc and still reverts back to old version.
Comment 1 Jose Gallardo 2016-12-21 17:51:47 UTC
This issue is already fixed.