Bug 37915 - ListView PullToRefresh does not appear on initial load
Summary: ListView PullToRefresh does not appear on initial load
Status: CONFIRMED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 2.0.0
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-01-22 16:41 UTC by John Miller [MSFT]
Modified: 2016-12-21 18:37 UTC (History)
3 users (show)

Tags: Android ac
Is this bug a regression?: ---
Last known good build:


Attachments
Sample Project (57.17 KB, application/zip)
2016-01-22 16:41 UTC, John Miller [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 37915 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description John Miller [MSFT] 2016-01-22 16:41:56 UTC
Created attachment 14674 [details]
Sample Project

**Overview:**

   If IsRefreshing is set to true, the PullToRefresh widget is not shown the first time.

**Steps to Reproduce:**

   1. Run the attached project on an Android device/emulator

**Actual Results:**

   Nothing appears on the screen. 
   After the 5 second delay, you can pull on the ListView and the PullToRefresh appears correctly.

**Expected Results:**

   The PullToRefresh widget should appear right away for 5 seconds, then disappear. 

**Build Date & Platform:**

   XF 2.0.1
   Android API 21
Comment 1 Joe Sauve 2016-01-22 16:54:35 UTC
+1

Same behavior exists in "Customers" demo app: https://github.com/xamarin/app-customers