Bug 3786 - [CoreImage] Constant Color Generator produces no output.
Summary: [CoreImage] Constant Color Generator produces no output.
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: 5.2
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Miguel de Icaza [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2012-03-07 13:20 UTC by Eric Beisecker
Modified: 2012-03-07 18:16 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Eric Beisecker 2012-03-07 13:20:47 UTC
Current Behavior: The ColorGenerator class produces a blank image.

Expected Behavior: The color generator should produce an Image of a solid color.

Sample Code:
		
public CIImage ConstantColorGenerator ()
{
	var color = new CIColor (new CGColor (77F, 247F, 250F)); // A nice Teal
	var colorGen = new CIConstantColorGenerator ()
	{
		Color = color
	};
	
	return colorGen.OutputImage;
}
Comment 1 Miguel de Icaza [MSFT] 2012-03-07 18:16:17 UTC
This was a bug in the sample.

It turns out that for filters that generate images without an input image there
is no region defined for the filter, so we must manually call Crop on the
resulting image to render.